Honda CBR 600RR Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
737 Posts
Discussion Starter #1 (Edited)
Well i dont know if any of you guys read my problem with my bike but, i got it back today and the shop told me it was the TPS....and he re adjusted the TPS, it ran fine for like 2 miles and back to **** again... i was wondering if you guys think is right that i payed 4hours a labor (70 anhour) for them to tell me its the tps and attempt to fix it which it didnt......also after like 30 minutes of taking it back to the house the oil light came on i pulled over and shut the bike of, when i turned the key it started blinking 8 times does this mean i have a problem with the oil system or is it just throwing out a code i need to know about? Also does anybody have a 03-04 throttle body they could help me out with? THANKS!
 

·
Registered
Joined
·
737 Posts
Discussion Starter #3
hey thanks a lot buddy atleast i know that part now. I kind of freaked out when i saw the oil light though! thought i was goign to lock up the motor at any second! phew. I guess i really need a new TB now...atleast i know thats the problem.
 

·
Registered
Joined
·
737 Posts
Discussion Starter #5
Bring it back and make them fix it. You payed them to fix it and it's obviously not.


yea the thing is i dont have anything to bring back to them to fix...they tried to fix it by adjusting the old TPS but obviously that only lasted a mile or so....they told me it wasnt a guranteed fix and that later on i would need to get a Throttle body, but i did expect more then a mile? I dont really know what to do...
 

·
Registered
Joined
·
737 Posts
Discussion Starter #6
no its the original TB, the thing is i have a bad TPS which is on the TB and they dont sell the tps by its self so i need to get a TB with a good TPS on it. No i didnt think i needed a Power commander for a slip on system.

Why do you need a new throttle body?
Did you replace your original?
Got a power commander?
 
1 - 13 of 13 Posts
Top