Honda CBR 600RR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
i recently laid my 05 600rr down on the right side at about 30 mph, the sliders saved most of it but the right turn signal was half broke off. I just got it all put back together and i put some flush mount signals on the front, they do not light up as if they were running lights, they are just off until i go to turn the signal on then they just come on but do not flash, ive checked all the fuses and they are fine, i also baught a integrated tailight with signals in it but havent put it in yet, so i have no rear signals, does anyone know what the problem could be? after i wrecked i tried turning the signals on and the stock ones did the same thing, they just turned on but did not blink.
 
K

·
Guest
Joined
·
0 Posts
it's a lack of electrical load that is your problem.

first of all, your old lights were 2 filiment (3 wires). your new lights are single "filiment" (2 wire)... so no running lights for you. your second problem is a lack of electrical load, as i said before. your turn signal relay works by electrical load. the more electrical load there is, the longer the interval will be. your previous load was 46 watts. since you don't have rear turn signals and you changed your front turn signals from 23 watt conventional lighting to low power LED lighting, you new load is somewhere in the neighborhood of 3 watts. your signal should be blinking, just ~15 times faster than it used to. to solve this problem, you need to either install electrical resisters OR bypass and replace your turn signal relay (which is integrated into the dash on all Gen1 and Gen 2 CBR600RRs) with one that operates on a time delay circuit (from CustomLED.com).

all instructions can be found on this website, mostly as stickies.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
is there any type of aftermarket signals that i could get that i wouldnt have to replace the relay?
 
K

·
Guest
Joined
·
0 Posts
you don't have to replace the relay... i thought i made that clear...

yes there are. Protons and Watsens. but what you do to the back effects the front.
 

·
Registered
Joined
·
585 Posts
it's not that hard to add resistors or a new relay. like kslug said, check out the stickies on this site, all the information you need.
 
1 - 5 of 5 Posts
Top