Honda CBR 600RR Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
my roomate has a 2006 cbr600rr with like 1700 miles. he washed it one day and then he went riding a lil later and his turn signal wouldnt work and niether the the brake light. i found the fuse that keeps popping i even took the turn signal switch apart and used eletrical cleaner and di electric grease on it and it still keeps popping everytime i turn the turn signal on. so can someone please help me figure out what the problem is so i can ride again?

thanks
bret
 

·
Registered
Joined
·
121 Posts
Pull the tail and disconnect all the lights. Replace the fuse and try the signals with everything dosconnected. If the fuse blows its most likely in the wiring along the frame back to the box or in the switch. If you have a meter test for continuity with the power off across different lines that run with the power lead to the lights. If you get a reading on anything but the same line they are touching. You can also check the continuity on the wire to the frame in multiple locations to see if its grounding out on the frame somewhere.
 

·
Registered
Joined
·
186 Posts
its easy you have wires touching somewhere, does it have aftermarket lights? and hold on.. if you found the fuse that keeps popping why did you need to know where the fuse box was? what fuse keeps popping?
 

·
Registered
Joined
·
952 Posts
It has to be wires touching somewhere. I had the same problem, and it turned out I had two wires touching with my integrated light. It would blow fuses. A re-tape job did the trick!
 

·
Registered
Joined
·
25 Posts
boo for tape, best bet is to use heat shrink tubing over connections. cost like $4 for a multi-pack with many different tube sizes. its the best to use for any connections
 
1 - 8 of 8 Posts
Top