Honda CBR 600RR Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
2003 honda cbr600rr no turn signals work on the right side of the bike at all. If you turn it on its just a solid right turn on the dash and doesnt blink on dash like the left. I assume it could be because the high beam mess but unsure. It is missing a right high beam headlight and its such a mess seems to have some kind of hid controller with bright leds or something. I can’t figure out whats going on here and it seems they got rid of the original wiring. I wanted to install a headlight bulb but it seems to take some specific one and i honestly can’t figure anything out and was hoping someone here can be more help. Will attach pictures. Thanks in advance.
Hood Automotive lighting Automotive tire Motor vehicle Automotive design

Automotive tire Hood Motor vehicle Automotive design Automotive lighting

Automotive tire Motor vehicle Bumper Automotive lighting Automotive design

Hood Light Automotive lighting Motor vehicle Automotive design

Automotive tire Automotive lighting Hood Bumper Motor vehicle
Automotive lighting Automotive tire Hood Motor vehicle Bumper
 

·
Registered
Joined
·
595 Posts
Greetings & Salutations! 👋

Turn signals, low & high beams are all separate circuits, so you've got at least three independent problems in your wiring. Get wiring diagram and trace wiring on your bike and revert back to 100% stock wiring configuration and lights will work like when it rolled off showroom floor.

See this thread on how to restore headlight connectors back to stock wiring: Any tips on this??


First thing I did on my bike after registering was to rip out HID on my bike and converted back to quality halogen bulbs from Philips (Narva, Osram, Toshiba also good). So much better control of beam without tonnes of glare into oncoming traffic's eyes. That creates very dangerous encountre for them and you when coming around corners and they get blinded.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the reply! I’ll definetly look into getting the original wiring for the headlights but like you said that would have nothing to do with the right turn signals not working right? I wonder what would be the cause of that not working.. thats really my main concern over the high beam i just assumed it might have had something to do with it.

Greetings & Salutations! 👋

Turn signals, low & high beams are all separate circuits, so you've got at least three independent problems in your wiring. Get wiring diagram and trace wiring on your bike and revert back to 100% stock wiring configuration and lights will work like when it rolled off showroom floor.

See this thread on how to restore headlight connectors back to stock wiring: Any tips on this??


First thing I did on my bike after registering was to rip out HID on my bike and converted back to quality halogen bulbs from Philips (Narva, Osram, Toshiba also good). So much better control of beam without tonnes of glare into oncoming traffic's eyes. That creates very dangerous encountre for them and you when coming around corners and they get blinded.
 

·
Registered
Joined
·
595 Posts
Odd that left & right winkers would operate differently since they both go through one flasher relay. As quick test, find and unplug flasher relay. Does both left and right side stop working?
 
1 - 5 of 5 Posts
Top