Honda CBR 600RR Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey everyone, here's the deal. I've been buying wrecked bikes and rebuilding them for a short while now but have run into the first problem I cannot figure out myself. This '08 cbr 600RR was in a front end crash at about 35mph... It didn't start when I bought it but figured it was something minor; hope I'm right....

What I know: I know it was laying down in the back of a truck for about a week so oil probably crept into the cylinders which means it needs and oil change and clean plugs.

What I've checked: I have checked all fuses under seat (good), have not looked at relays. BAS is in correct position. full charge on battery @ 13V. Radiator is also busted and no more coolant in it... maybe a factory safety feature stops engine from cranking with no coolant..?

What's odd to me, maybe not to you, is I when I tried to start it, the fuel pump DID prime but would not turn over (starter maybe? just seemed unlikely on newer model)...not clicking...nothing. Also headlights are not on. They are HID's but bulbs look like in good shape... One more question, is there anything special I have to do for the oil change since it was on it's side or will normal oil change be fine? and where is the general area of the plugs so I can pull them out and clean em up?

...sry for the long post...
 

·
Premium Member
Joined
·
13,137 Posts
Check the start switch then the starter solenoid etc...

Clean the oil out of the airbox...

And the plugs are behind the radiator...
 
1 - 2 of 2 Posts
Top