2003 600rr no crank (kill switch issues?) - 600RR.net
General Discussion General Honda CBR600RR Motorcycle Talk - please place mods, tech tips and off topic threads in the correct forums.

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 05-13-2019, 12:42 AM Thread Starter
Training Wheel Hero
 
Join Date: May 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 600rr no crank (kill switch issues?)

Purchased 2003 600rr couple weeks ago with a half broken kill switch button (worked perfectly fine but wanted to replace anyways). Purchased a good used kill switch unit and tried to replace today. I was unsuccessful taking off throttle tube, didn't have enough time, had to get ready for mothers day. So decided to put everything back together and figure it out on my day off. After getting it back together I turned on engine but it cranked slower than usual but started, i shut her off and did this about 3-4 times. All of a sudden it just stopped cranking. When i press start button the headlight just turns off and back on. I also dont hear the fuel pump prime anymore.

Any ideas what could have gone wrong ?
licketysplit is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-13-2019, 12:49 AM
BOTY 2014 Winner
 
Join Date: Oct 2013
Posts: 4,443
Thanks: 13
Thanked 998 Times in 818 Posts
Garage
Feedback Score: 3 reviews
if the pump doesn't prime the kill switch isn't satisfied.

the start button shuts off the headlights, that's normal.
wibbly is offline  
post #3 of 7 (permalink) Old 05-13-2019, 01:00 AM Thread Starter
Training Wheel Hero
 
Join Date: May 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by wibbly View Post
if the pump doesn't prime the kill switch isn't satisfied.

the start button shuts off the headlights, that's normal.
ok kill switch is faulty.
licketysplit is offline  
 
post #4 of 7 (permalink) Old 05-13-2019, 01:18 AM
BOTY 2014 Winner
 
Join Date: Oct 2013
Posts: 4,443
Thanks: 13
Thanked 998 Times in 818 Posts
Garage
Feedback Score: 3 reviews
Probably..
wibbly is offline  
post #5 of 7 (permalink) Old 05-13-2019, 09:35 AM
Training Wheel Hero
 
indfireblade's Avatar
 
Join Date: May 2018
Posts: 31
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Check all the solder connections on the switch and also take it apart and clean the contacts real good. Then try again
indfireblade is offline  
post #6 of 7 (permalink) Old 05-15-2019, 12:50 AM Thread Starter
Training Wheel Hero
 
Join Date: May 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
replaced kill switch unit, started right up. thanks!
licketysplit is offline  
post #7 of 7 (permalink) Old 05-16-2019, 09:23 AM
Training Wheel Hero
 
indfireblade's Avatar
 
Join Date: May 2018
Posts: 31
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Good Deal!
indfireblade is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP: Installed LP Integrated TL now NO Headlight & High Beam **Kill switch wire ** omie_cbr Troubleshooting 8 06-05-2014 01:54 AM
Use kill switch as ignition switch? champ955 07-13 RR Modifications 8 02-14-2012 10:13 PM
No crank no start on my 05 Tipys Troubleshooting 11 06-11-2009 04:40 PM
Kill Switch Upgrade 06 to an 07 switch. Need Wiring Help tidrow55 03-06 RR Modifications 3 10-22-2008 11:46 PM
Zuki Squids...no no no no no. Meddiepie954rr Off Topic & Flame Thrower 6 11-05-2004 12:31 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome