Armour Bodies Dzus hitting rad and/or rad hose/guard - 600RR.net
Trackdays Privateers and Professionals
Sponsored by: MOTO-D Racing

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 08-08-2014, 03:55 PM Thread Starter
Training Wheel Hero
 
Join Date: Jul 2008
Location: Edmonton, Canada
Posts: 81
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Armour Bodies Dzus hitting rad and/or rad hose/guard

So I'm just in the process of finalizing my Armour Bodies install. Fitment is 90% overall, but I have one small issue. I can get only one dzus clip style on the left lower/upper seam; the second one keeps hitting the rad hose or sheath (rubber guard) or the radiator, or the radiator hose clamp. I can't get the clip installed without hitting something. Have tried pretty much from the middle to the front (of bike) and nothing seems to work.

The best spot so far is the between the rad hose clamp (between the tail and ring where the bolt is). When I mount the lower fully, will it pull the upper outwards slightly?
Flashpoint is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-09-2014, 04:25 PM
Moto GP Racer
 
FightingChance's Avatar
 
Join Date: Apr 2007
Location: Los Angeles, CA
Posts: 7,043
Thanks: 0
Thanked 700 Times in 601 Posts
Feedback Score: 10 reviews
Pics?

It seems as easy has just locating the mounts away from anything they'll touch in the back, but maybe I'm not thinking of what you're doing.
FightingChance is offline  
post #3 of 3 (permalink) Old 08-11-2014, 12:31 PM Thread Starter
Training Wheel Hero
 
Join Date: Jul 2008
Location: Edmonton, Canada
Posts: 81
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by FightingChance View Post
Pics?

It seems as easy has just locating the mounts away from anything they'll touch in the back, but maybe I'm not thinking of what you're doing.
Managed to get it all sorted out, in order to space them far enough apart and not hit the rad/hoses I had to spin the rad hose clamp as the dzus was butting up against it. After doing that I had enough clearance.
Flashpoint is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome