05 RR - FI light on dash? - 600RR.net
Exhaust & Fuel Delivery Tips on how to get the most out of your bike

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 08-10-2009, 03:22 AM
kris
Guest
 
Posts: n/a
05 RR - FI light on dash?

Hi Guys, when i put the key in prior to starting, the FI light comes on and then disappears once running.. is that normal? I cant recall seeing it be displayed ever...

Just wanted to check..
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-10-2009, 07:39 AM
AMA Supersport Racer
 
kidnplay01's Avatar
 
Join Date: Oct 2008
Location: Oz Land Down Under
Posts: 1,308
Thanks: 0
Thanked 40 Times in 28 Posts
Feedback Score: 0 reviews
Normal..you may breathe again

Ohlins- Fork Springs, Shock, S.D, UES Kit 20mm, PCIII, Velocity Stack mod, RS-5 C.F Yoshi, Dynoed, K&N Air Filter, Cox Radiator Guard, Powers Race Railz mod, MOTY Battery, Pazzo Levers, Harris Grips, Stomp Grips, Ram mounting, Custom Fairings, Custom led gauges, C.F -Hugger-Sprocket cover,Exhaust,Heel, Chain, Engine,& clutch guards. Trippage led pegs, 520 Conv, -1 +2 Superlight Sprocket, Comp werkes FE, Dunlop Q2's, EBC Kevlar Heavy Duty Clutch/Springs, Vesrah RJL Pads,Braided brake lines
kidnplay01 is offline  
post #3 of 3 (permalink) Old 08-10-2009, 08:20 AM
kris
Guest
 
Posts: n/a
Ahhh i feel better now :D
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome