2 Brothers Slip On=PC III??? or Not - 600RR.net
Exhaust & Fuel Delivery Tips on how to get the most out of your bike

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 08-16-2009, 06:41 PM Thread Starter
 
Join Date: Jul 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2 Brothers Slip On=PC III??? or Not

After searching for a slip on exhaust for my 2004 600RR I finally got a used 2 brothers. Put them on with no problem, just a little wiggle here and there and she looked pretty straight from behind. Anyway, I always read that these things are plug and play with no need of fuel/mix adjustments. I notice my idling is going up and down (not steady smooth) between 1k-1.5k after the installation. Why is that? I went for a ride and rev up at around 7k-8k hoping things will get better, but it didn't. Does this mean it time to look for a Power Commander? If that is the case then I'm OK with that. What should I look for? Are they all the same as long as I download the correct mapping for my bike/exhaust?:book1:
Father of 2 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-16-2009, 06:42 PM
Chief IronLungs
 
cbrRedRag's Avatar
 
Join Date: Feb 2007
Location: 360, WA
Posts: 2,000
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 8 reviews
the idle rate is 1.3, youre ok

Hit busters on the head like Vonage
* Im not rude, youre just insignificant


cbrRedRag is offline  
post #3 of 6 (permalink) Old 08-16-2009, 07:19 PM
Training Wheel Hero
 
sluggo's Avatar
 
Join Date: Aug 2007
Location: oklahoma
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I installed a Leo Vince s/o on my 04 and it does the same thing. I have noticed that it also runs a little rich. I think I will probably end up getting a power commander to try and take care of the running rich problem.
sluggo is offline  
 
post #4 of 6 (permalink) Old 08-16-2009, 07:20 PM Thread Starter
 
Join Date: Jul 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by cbrRedRag View Post
the idle rate is 1.3, youre ok
Yeah its at 1.3 but but not idling smooth. If I would just release the clutch slowly without reving, I move forward with a jerking motion. If you know what I mean.
Father of 2 is offline  
post #5 of 6 (permalink) Old 08-18-2009, 12:07 PM
AMA Supersport Racer
 
itz.damenace's Avatar
 
Join Date: Jun 2005
Location: DC Baby! => Hotlanta
Posts: 668
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
I was wondering the same thing...I had an 2Bros Slip-on & an K&N Filter installed as well over a week ago. I wonder if I needed an PCIII my bike currently has approx 84xx miles. I definitely feel the difference in the power.
Then I looked in the section that has dyno's in it. I didnt find one with a stock dyno for an 05.


- Subscribed

*******************************
2005 Black Tribal


Facebook Me
itz.damenace is offline  
post #6 of 6 (permalink) Old 08-18-2009, 12:58 PM
Training Wheel Hero
 
Join Date: Jan 2009
Location: Auburn, AL
Posts: 48
Images: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
if you have a two bros exhaust you should consider a two bros juice box ( same thing as a power commander just cheaper)...make sure to take it to a shop unless you are a motorcycle guru with tons of mapping knowledge
GarrettS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome