New Arrow+CA taillight? - 600RR.net
Exhaust & Fuel Delivery Tips on how to get the most out of your bike

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 09-11-2009, 09:09 PM Thread Starter
Training Wheel Hero
 
Join Date: Sep 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New Arrow+CA taillight?

Hi, anyone try the new arrow on 08(carbon end cap) + CA taillight? check some pics seems can fit perfect as the Leo Vince,anyone done and got some pics? thanks!

Last edited by colinrex; 09-11-2009 at 09:11 PM.
colinrex is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-01-2009, 02:38 PM
Moto GP Racer
 
thaghost's Avatar
 
Join Date: Feb 2009
Location: Romeoville, IL
Posts: 2,503
Thanks: 104
Thanked 150 Times in 110 Posts
Feedback Score: 4 reviews
bump...looking for some too




PLEASE READ THE CLASSIFIED RULES BEFORE POSTING CLASSIFIED RULES
thaghost is offline  
post #3 of 3 (permalink) Old 10-04-2009, 09:27 AM
Pocketbike Racer
 
razerreg's Avatar
 
Join Date: Jul 2006
Location: sin city
Posts: 283
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 16 reviews
razerreg is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome