ktautoparts - 600RR.net
Vendor Experiences The Good, the Bad and the downright Ugly

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 07-23-2015, 02:09 PM Thread Starter
Training Wheel Hero
 
Join Date: May 2012
Location: essex ,england
Posts: 80
Thanks: 3
Thanked 11 Times in 10 Posts
Feedback Score: 0 reviews
Unhappy ktautoparts

has anyone else had experience with this company. purchased a headlight from them and delivery and packaging was spot on and i had no complaints. after my first ride i noticed the high beam was not working. i checked all the cables and emailed them. the response was quick and i mentioned the problem and they suggested i check the cables, i said i had and they asked me to do a video and email. they sent a new relay and wiring.i tried it ,it still didn't work.since this i have emailed them 3 times and every time they say try wiring it like this etc.etc. but none of this works.it seams they are giving me the run around and this has now been going on for at least a month. it's the best time of the year to ride ,i have no mot and connot therefore ride.... arrrrrrgggggggggggggggh! i have just emailed again and this has to be last chance...
davey666 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-23-2015, 03:12 PM
AMA Supersport Racer
 
digdah's Avatar
 
Join Date: Nov 2012
Location: Dallas
Posts: 940
Thanks: 4
Thanked 141 Times in 115 Posts
Feedback Score: 0 reviews
Did you search this forum? I'm pretty sure this has been addressed before.
digdah is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome