What is wrong with my clutch? - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 06-18-2008, 10:23 PM Thread Starter
Knee Dragger
 
Ballz's Avatar
 
Join Date: Mar 2006
Location: White Plains, New York
Posts: 137
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What is wrong with my clutch?

Quick version: Crashed. Rebuilding into a streetfighter. Damage was mostly to the left side... stator cover, flywheel, etc. Fixed all of that. Now, the bike runs, but the clutch wont disengage. I removed the right-side engine case, and all the gears seem to be in tact. Every time I start it and kick it into first, it lurches and stalls. Cable is connected, etc. I even moved the lever (over the engine case) with my hand and nothing. There is no resistance on the lever either (besides the slight amount the spring provides). Anyone have an idea? Oh, and there is not too much oil... I checked that. Any help would be appreciated. Thanks.

Comp Werks Fender Eliminator
Corbin Seat
Custom Paint
Dr X (VFX) Integrated Tail
Eye Candy Spikes
LED Backlighting / Ground Effects / Halo Kit
Speedohealer
Sportech Windscreen
Tripage LED Rear Pegs
Tripage Powdercoating
Two Bros C-5 Exhaust
Vortex -1/+3 w/ DID 520 Conversion
Watsen Design Blinkers

Last edited by Ballz; 06-18-2008 at 10:25 PM. Reason: revision
Ballz is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-18-2008, 10:54 PM
World Superbike Racer
 
Stu-Pac's Avatar
 
Join Date: May 2007
Location: Lincoln, NE
Posts: 1,824
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i would check the cable? i know u checked to see if it was connected but check the cable.
Stu-Pac is offline  
post #3 of 9 (permalink) Old 06-19-2008, 10:00 AM
AMA Supersport Racer
 
sethr21785's Avatar
 
Join Date: Oct 2006
Location: OOB MAINE
Posts: 595
Images: 2
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 14 reviews
try disconnecting the cable on the clutch cover and see if that disengages it..

Quote:
Originally Posted by Knightslugger View Post
who fuking cares, really guys. get the sand out of the vagges.
sethr21785 is offline  
 
post #4 of 9 (permalink) Old 06-19-2008, 11:17 AM Thread Starter
Knee Dragger
 
Ballz's Avatar
 
Join Date: Mar 2006
Location: White Plains, New York
Posts: 137
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
^^^^^^^^^^^
I did disconnect the cable from the cover. Moved the lever by hand. Can't get the clutch to disengage. Won't disengage ever, no matter what. I have no idea why.

Comp Werks Fender Eliminator
Corbin Seat
Custom Paint
Dr X (VFX) Integrated Tail
Eye Candy Spikes
LED Backlighting / Ground Effects / Halo Kit
Speedohealer
Sportech Windscreen
Tripage LED Rear Pegs
Tripage Powdercoating
Two Bros C-5 Exhaust
Vortex -1/+3 w/ DID 520 Conversion
Watsen Design Blinkers
Ballz is offline  
post #5 of 9 (permalink) Old 06-19-2008, 03:37 PM
 
Join Date: Jul 2007
Posts: 3,672
Thanks: 0
Thanked 14 Times in 11 Posts
Feedback Score: 7 reviews
just take the clutch cover off and see whats up on the inside
RShackleford is offline  
post #6 of 9 (permalink) Old 06-19-2008, 03:52 PM
Moto GP Racer
 
MXRider's Avatar
 
Join Date: Mar 2007
Location: Virginia
Posts: 9,216
Thanks: 70
Thanked 144 Times in 91 Posts
Feedback Score: 17 reviews
maybe the shaft that actuates the clutch isnt installed properly?
MXRider is offline  
post #7 of 9 (permalink) Old 06-19-2008, 04:58 PM Thread Starter
Knee Dragger
 
Ballz's Avatar
 
Join Date: Mar 2006
Location: White Plains, New York
Posts: 137
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by MXRider View Post
maybe the shaft that actuates the clutch isnt installed properly?
I took off the cover. All the gears seem to be in tact. The rod that actuates the clutch catches another shaft when turned. I think its supposed to pull it out. It seems like that is all connected properly, but I cant get the clutch to disengage. I even tried to pull it out by hand, and I cant move it.
Is there a chance that one of the internal clutch springs is damaged from the crash?
This is frustrating.

Comp Werks Fender Eliminator
Corbin Seat
Custom Paint
Dr X (VFX) Integrated Tail
Eye Candy Spikes
LED Backlighting / Ground Effects / Halo Kit
Speedohealer
Sportech Windscreen
Tripage LED Rear Pegs
Tripage Powdercoating
Two Bros C-5 Exhaust
Vortex -1/+3 w/ DID 520 Conversion
Watsen Design Blinkers
Ballz is offline  
post #8 of 9 (permalink) Old 06-20-2008, 07:55 AM
 
Join Date: Jul 2007
Posts: 3,672
Thanks: 0
Thanked 14 Times in 11 Posts
Feedback Score: 7 reviews
pull the entire clutch
springs, plates, everything

see if you see something wrong
RShackleford is offline  
post #9 of 9 (permalink) Old 06-25-2008, 02:49 PM Thread Starter
Knee Dragger
 
Ballz's Avatar
 
Join Date: Mar 2006
Location: White Plains, New York
Posts: 137
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
^^^^^^^^^^^^^^^^^^^^^^^^
What would be visibly wrong? Broken spring or something? Could that have happened from the crash?

Comp Werks Fender Eliminator
Corbin Seat
Custom Paint
Dr X (VFX) Integrated Tail
Eye Candy Spikes
LED Backlighting / Ground Effects / Halo Kit
Speedohealer
Sportech Windscreen
Tripage LED Rear Pegs
Tripage Powdercoating
Two Bros C-5 Exhaust
Vortex -1/+3 w/ DID 520 Conversion
Watsen Design Blinkers
Ballz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome