Rear Brake Light Not Working Correctly? Help!! - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 06-24-2008, 09:59 AM Thread Starter
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Rear Brake Light Not Working Correctly? Help!!

Proud new owner of a '03 600rr, and new to this forum. I was hoping someone could help me out with a break light issue:

When I use my rear (foot) brake, the brake light responds and lights up correctly, but every time I use my front (hand) brake, the brake light DOES NOT light up? Is there a simple fix or do I need to take it in to the shop?

Thanks!
Attached Thumbnails
Click image for larger version

Name:	bike1.JPG
Views:	58
Size:	42.8 KB
ID:	7704  

Last edited by mtms; 06-24-2008 at 10:01 AM.
mtms is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-24-2008, 10:15 AM
 
Join Date: Jul 2007
Posts: 3,672
Thanks: 0
Thanked 14 Times in 11 Posts
Feedback Score: 7 reviews
does the front brake click when you pull it.

that clicking is the brake switch coming on.

there should a small square box under the master cylinder with 2 wires going into it.

that is your brake switch.

if you pull those two wires off and connect the terminals of the wires together the brake light should come on.
RShackleford is offline  
post #3 of 7 (permalink) Old 06-24-2008, 11:40 AM Thread Starter
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
when i looked at my brake switch the two wires weren't even connected! so i connected them to the brake switch and now the brake lights stay on all the time?

if i disconnect them, then only the foot brake makes the break light light up, but the handbrake doesn't???

any more suggestions?
mtms is offline  
 
post #4 of 7 (permalink) Old 06-24-2008, 12:43 PM Thread Starter
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My brake light is non responsive to hand brake?!

I noticed this morning on my way to work that my break light doesn't light up with i press my hand brake, but it does when i press my foot brake.

I checked out my break switch, and the two wires were completely disconnected from the break switch. So when i re-attached them, the break light is continuously on, regardless of whether or not i'm pressing the breaks............then i switched around the connection the brake light goes off, but doesn't react to me pressing the breaks??

any guidance on a quick fix?

thanks
mtms is offline  
post #5 of 7 (permalink) Old 06-24-2008, 01:00 PM
 
Join Date: Jul 2007
Posts: 3,672
Thanks: 0
Thanked 14 Times in 11 Posts
Feedback Score: 7 reviews
sounds like they unhooked it because there is a short in the switch.
all that switch does is complete the circuit.
sounds like you need a new switch
RShackleford is offline  
post #6 of 7 (permalink) Old 06-24-2008, 05:27 PM
 
Join Date: Jun 2006
Posts: 394
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 11 reviews
Welcome to the site.
fwb600rr is offline  
post #7 of 7 (permalink) Old 07-01-2008, 11:24 PM
Training Wheel Hero
 
jmosesso's Avatar
 
Join Date: Apr 2007
Location: Morgantown, WV
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
i have this same problem but in reverse, mine lights up fine with the hand brake but nothing for the foot brake... is there a switch for the back as well?

jmosesso is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome