Noob w/turn signal problem - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 08-02-2008, 11:12 PM Thread Starter
 
Join Date: Jul 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Noob w/turn signal problem

I installed flushmount turn signals along with an integrated turn signals on the back but it seems like my front and back right turn signals only light up when i try to signal (doesnt flash). Here's the kicker, the front and back right signals will work perfectly as long as i use the left first and then use the right (confusing enough for you?). I checked the fuses and everything is good? It was working before for a couple of months and now i get this. Is it the wiring?
Nova1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-02-2008, 11:18 PM
Knee Dragger
 
05//Blk6rr\\Cali's Avatar
 
Join Date: Jul 2008
Posts: 141
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you need to add in resistors. Search for flushmount turn signals. they will explain what ones and where to get them. if its a 07-08 i think you can just buy a new flasher for like $20.00 hope that helps
05//Blk6rr\\Cali is offline  
post #3 of 5 (permalink) Old 08-02-2008, 11:25 PM
Demented
Guest
 
Posts: n/a
If they're LED's or single filament bulbs, they wont light up as a running light like the stockers do.
 
post #4 of 5 (permalink) Old 08-03-2008, 12:18 PM Thread Starter
 
Join Date: Jul 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hey guys, thanks for the replies. I checked and it doesnt have any resistors so i might have to add those for the lights to work perfectly.
Nova1 is offline  
post #5 of 5 (permalink) Old 08-03-2008, 12:29 PM
Pocketbike Racer
 
FLryder's Avatar
 
Join Date: Jul 2007
Location: Tampa Bay
Posts: 489
Images: 1
Thanks: 11
Thanked 36 Times in 32 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by 05//Blk6rr\\Cali View Post
you need to add in resistors. Search for flushmount turn signals. they will explain what ones and where to get them. if its a 07-08 i think you can just buy a new flasher for like $20.00 hope that helps
He's right you need the resistor to allow it to work. $20 and you can mount it inside the upper cowl.

04- 600rr Black & gray(Stolen)
05- 600rr Black Tribal (Sold)
05- 600rr Black
FLryder is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome