Please Help Can't figure out whats wrong - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 09-02-2008, 08:26 PM Thread Starter
 
Join Date: Aug 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Please Help Can't figure out whats wrong

I replaced the stator cover this weekend on my bike. I took the bike out yesterday and at the end of the ride i had to pop the clutch to get it home. The display went out as well. I charged the battery and took it back out on the road today and the bike would not run. When I finally got back home the battery charger says that the battery is fully charged. Also the display would only show the time but if you wait another second the full display will come up. when you engage the starter it just clicks. Could I have gooned up the re-install of the stator cover? Or is their another issue at play?
ferh84 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-02-2008, 08:36 PM
 
Join Date: Oct 2007
Posts: 810
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
That seems highly likely..
Diving Pete is offline  
post #3 of 7 (permalink) Old 09-02-2008, 08:47 PM
 
Join Date: Jul 2007
Posts: 3,672
Thanks: 0
Thanked 14 Times in 11 Posts
Feedback Score: 7 reviews
did you rememeber to plug it back in?
stator covers are pretty straight forward.

stator actually bolted in and plugged in?
cover sealed and not leaking?

thats about all there is to it
RShackleford is offline  
 
post #4 of 7 (permalink) Old 09-02-2008, 08:55 PM Thread Starter
 
Join Date: Aug 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I checked the connections on it and I never unpluged it, Maybe thats the problem? However if the battery and stator are dead I shouldn't be able to push start it should I? Those are the only source of power so If they were both bad their wouldn't be a source of power for the spark plugs to draw from. Also the bike has been at low rpm for the past two weeks.
ferh84 is offline  
post #5 of 7 (permalink) Old 09-02-2008, 09:00 PM Thread Starter
 
Join Date: Aug 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Also since the bike is a year old could the problem be the regulator/rectifier? thanks for all the help
ferh84 is offline  
post #6 of 7 (permalink) Old 09-02-2008, 09:15 PM Thread Starter
 
Join Date: Aug 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
one more question. Can the Alternator bypass the battery to power the ignition system or does it have to go through the battery to power the ignition system.
ferh84 is offline  
post #7 of 7 (permalink) Old 09-02-2008, 09:20 PM
Knee Dragger
 
Join Date: Mar 2008
Posts: 176
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
I can answer the last one - no battery and the bike doesn't run - check the electrical connectors and hte ground. then check your fuses - then if slugger is around bug him for the pin out ohm check on the stator connector if the first 2 don't show anything (I know it's in another post in here somewhere tho)
twilkinson3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome