I've had it with my battery! - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 09-28-2008, 07:51 PM Thread Starter
World Superbike Racer
 
Kingdom Racing's Avatar
 
Join Date: Aug 2008
Location: San Diego, CA
Posts: 1,602
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've had it with my battery!

Ive had it, I am buying a new battery can u guys recommend one for my 07 -08 RR?

Thanks a bunch!

Kingdom Racing is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-28-2008, 08:05 PM
Post Whore Extraordinaire
 
snikwad's Avatar
 
Join Date: May 2005
Location: Goldsboro, NC
Posts: 19,904
Images: 15
Thanks: 23
Thanked 29 Times in 28 Posts
Feedback Score: 16 reviews
I'm guessing you bike keeps dieing and its not charging?
It may not be your battery.
You need to get a voltmeter, put it on the terminals at idle, shouldn't be less than 12v.
Then rev it up to about 5k rpm and hold. If the voltage is less than 13v its not your battery, its your charging system.

Here's the trick. You can buy a used rectifier/regulator on ebay and try that. If it works then good, if not its your stator, and those are more expensive.

No more mod listing, shits is STILL too long

03 600RR > 04 1000RR > 06 R6V > 05 600RR > 06 R1 > 09 1000RR > 10 RSV4R :gun:
snikwad is offline  
post #3 of 4 (permalink) Old 09-28-2008, 08:08 PM
Post Whore Extraordinaire
 
snikwad's Avatar
 
Join Date: May 2005
Location: Goldsboro, NC
Posts: 19,904
Images: 15
Thanks: 23
Thanked 29 Times in 28 Posts
Feedback Score: 16 reviews
If you go on 1000rr.net you can read up about the stator issue with those bikes. You can read about all the symptoms. Like fluttering instument panel, sputtering, spikey acceleration and all that. I just changed mine like a month or so ago.

No more mod listing, shits is STILL too long

03 600RR > 04 1000RR > 06 R6V > 05 600RR > 06 R1 > 09 1000RR > 10 RSV4R :gun:
snikwad is offline  
 
post #4 of 4 (permalink) Old 09-29-2008, 12:29 AM Thread Starter
World Superbike Racer
 
Kingdom Racing's Avatar
 
Join Date: Aug 2008
Location: San Diego, CA
Posts: 1,602
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the help bro, anyone else?

Kingdom Racing is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome