signal lights don't work! - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 01-08-2009, 11:04 PM Thread Starter
AMA Supersport Racer
 
bullshat830's Avatar
 
Join Date: Jul 2008
Location: Oceanside, CA
Posts: 726
Thanks: 24
Thanked 6 Times in 3 Posts
Feedback Score: 4 reviews
signal lights don't work!

somebody dropped my bike about 2 weeks ago. it fell on the left side of the bike and my left gixxer mirror signal doesnt work. but my left flushmount turn signal works, so does the right turn signal and the rear turn signals work. also my turn signal indicator works.

earlier when i was riding they worked, about 5 mins into the ride, i used my turn signal, none of them worked and the turn signal indicator doesnt work either.

how can i fix this?



'06 600RR
check out my build thread!
https://www.600rr.net/vb/showthread.php?t=181895


bullshat830 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-08-2009, 11:16 PM
AMA Supersport Racer
 
SchaadeS's Avatar
 
Join Date: Mar 2008
Location: Edmonton
Posts: 962
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 4 reviews
Check your fuses... when the gixxer mirror stopped working it may have caused a short in it. I'd say check your fuses, replace if neccessary retry signal lights it it blows again you should take your gixxer mirror off the circuit and try again. Guess and test man, guess and test. Only thing your losing is little 20cent fuses

-Shelby
https://www.600rr.net/vb/showthread.php?t=124351

D3 Grips, O'Grady Paint, Powder coated everything, Custom LED switching, Tripage Third Eye, Custom LED Gauge Cluster, 6000K HID's, Integrated Mirrors with Signals, Integrated Signal/Brake light, Driven Sprocket Kit -1/+2, EK Chain 520 Pitch, PC3, Quickshift kit, Multi mapping touch screen, Block Off Plates, BCM Air Filter, DIY Short stack Air Mod, Speedohealer, Galfer Stainless Steel Brake lines, 450R mod, Yoshi pipe, Arrow Headers.
SchaadeS is offline  
post #3 of 3 (permalink) Old 01-09-2009, 12:44 AM Thread Starter
AMA Supersport Racer
 
bullshat830's Avatar
 
Join Date: Jul 2008
Location: Oceanside, CA
Posts: 726
Thanks: 24
Thanked 6 Times in 3 Posts
Feedback Score: 4 reviews
ok, thanks a lot dude. i'm just gonna put the OEM mirrors back on.



'06 600RR
check out my build thread!
https://www.600rr.net/vb/showthread.php?t=181895


bullshat830 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome