07 fuel pump willnt turn on?? Whats up? - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 03-03-2009, 06:51 PM Thread Starter
Training Wheel Hero
 
Join Date: Feb 2008
Location: Metro Detroit
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
07 fuel pump willnt turn on?? Whats up?

The days are getting warm so i grabbed the battery out of my room and went to throw it in the rocket and it was dead. Started before i took it out...Have not touched it since. Its on the charger now and it will fire with help from the throttle, but it will only say running for a few seconds...I don't hear the pump?......I checked the FI fuse and it was fine. any ideas?
batilzown is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-03-2009, 10:54 PM
World Superbike Racer
 
dcope17's Avatar
 
Join Date: Feb 2007
Location: Dana Point, Ca
Posts: 2,120
Thanks: 0
Thanked 12 Times in 11 Posts
Feedback Score: 1 reviews
Check all the fuses. If good you say the bike starts but won't run and the fuel pump doesn't run.

switch the fuel pump relay with the headlight or radiator fan relay. if that doesn't fix it. Then you have to start going through the wiring to find out what it is.

Ride hard today, Ride harder tomorrow,!
Walk close to Christ today, Walk closer tomorrow

How to fix headlights... Dreamzboy's excellent write-up
https://www.600rr.net/vb/showthread.php?t=138034
dcope17 is offline  
post #3 of 5 (permalink) Old 03-04-2009, 09:58 AM
Training Wheel Hero
 
Quagmire's Avatar
 
Join Date: Feb 2009
Location: Iron Mountain, MI
Posts: 73
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Let the battery charge fully (14 hours), then change your spark plugs. If you are running the Iridium plugs, they are extremely finicky. Usually get about 5,000 miles from a set of plugs then they have to be replaced.

If the bike starts, you are getting some fuel there, the pump won't deliver fuel without power (voltage). Did you put "Sta-bil" in the tank before storing? Could be bad gas too. But, it sounds like bad spark plugs to me.

Last edited by Quagmire; 03-04-2009 at 10:02 AM.
Quagmire is offline  
 
post #4 of 5 (permalink) Old 03-04-2009, 11:53 AM
World Superbike Racer
 
dcope17's Avatar
 
Join Date: Feb 2007
Location: Dana Point, Ca
Posts: 2,120
Thanks: 0
Thanked 12 Times in 11 Posts
Feedback Score: 1 reviews
How do bad spark plugs keep the fuel pump from running?

Ride hard today, Ride harder tomorrow,!
Walk close to Christ today, Walk closer tomorrow

How to fix headlights... Dreamzboy's excellent write-up
https://www.600rr.net/vb/showthread.php?t=138034
dcope17 is offline  
post #5 of 5 (permalink) Old 03-04-2009, 12:07 PM
 
tripage's Avatar
 
Join Date: Jun 2004
Location: orlando
Posts: 14,330
Thanks: 598
Thanked 728 Times in 591 Posts
Feedback Score: 91 reviews
How long has the bike been sitting? Bad gas sitting= bad fuel pump. T




http://tripageled.com/store/
Owner
Tristan Page
[email protected]
[email protected]
Dual low / Dual High beam led headlights. OEM appearance
http://tripageled.com/store/index.ph...product_id=236
Integrated Gear Indicator installed inside your cluster
http://tripageled.com/store/index.ph...product_id=116
tripage is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome