Neutral problem - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 07-13-2009, 09:09 PM Thread Starter
Training Wheel Hero
 
Join Date: Jul 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Neutral problem

I have a 2007, and the neutral light doesnt work like it should. When I first turn the key, the light comes on, but then when the bike is on and in neutral it doesnt work at all. Can anyone help. I know the wire is hooked up correctly because I removed the switch and the indicator and they all look fine.
Mecaman is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-14-2009, 11:31 AM
Knee Dragger
 
Join Date: Sep 2006
Location: Tallahassee, Fl
Posts: 186
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
maybe the nutral switch is bad
02blueR6 is offline  
post #3 of 6 (permalink) Old 07-14-2009, 02:28 PM
World Superbike Racer
 
dcope17's Avatar
 
Join Date: Feb 2007
Location: Dana Point, Ca
Posts: 2,120
Thanks: 0
Thanked 12 Times in 11 Posts
Feedback Score: 1 reviews
Bad switch, bad connection, broken wire. All these can cause your problem.

Take the wire off the switch and touch it to the crankcase. Does it light up, then the wire is good, then it's just the switch or connection. Just eliminate one possibility at a time.

Ride hard today, Ride harder tomorrow,!
Walk close to Christ today, Walk closer tomorrow

How to fix headlights... Dreamzboy's excellent write-up
https://www.600rr.net/vb/showthread.php?t=138034
dcope17 is offline  
 
post #4 of 6 (permalink) Old 07-16-2009, 07:53 AM Thread Starter
Training Wheel Hero
 
Join Date: Jul 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Today I tried removing the wire, and grounding it, and nothing happened. When I removed the wire from the neutral switch the idle went a little low. I also replaced the switch with a new one, and still nothing. I think the wire is good because the bike wouldnt start unless the wire was grounded. but still no light. Thank you for your suggestions. Anything else I can look at?
Mecaman is offline  
post #5 of 6 (permalink) Old 07-16-2009, 11:38 AM
World Superbike Racer
 
dcope17's Avatar
 
Join Date: Feb 2007
Location: Dana Point, Ca
Posts: 2,120
Thanks: 0
Thanked 12 Times in 11 Posts
Feedback Score: 1 reviews
let me look at the wiring diagram after work and I'll get back to you.

Ride hard today, Ride harder tomorrow,!
Walk close to Christ today, Walk closer tomorrow

How to fix headlights... Dreamzboy's excellent write-up
https://www.600rr.net/vb/showthread.php?t=138034
dcope17 is offline  
post #6 of 6 (permalink) Old 07-16-2009, 01:52 PM
 
Join Date: Jul 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my 04 was doing the same thing.. i would put it in neutral but the light wouldn't appear and i couldn't leave the bike running in neutral with the kickstand down cause it wasn't recognizing... all i did was take off the connect which was located directly above the gear lever and make sure all wires were touching... it works fine now
SpecialK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome