Turn Signals - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 09-15-2010, 02:20 PM Thread Starter
Knee Dragger
 
HighlyFavored0420's Avatar
 
Join Date: Jun 2008
Location: Moore, OK
Posts: 248
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Turn Signals

I'm having issues with my turn signals. Before replacing my iSuck light with the new IT light, it was having the same problem, so I know it's not the new light.

The front signals work just fine, and the rear left signal works as well. The rear right signal does not work, even though the front signal does. I have checked all fuses, and obviously the relay is good or the other signals would not be working. Any idea on where to start?

'08 motofans custom - crg, akra, puig db, watsens, audi, IT tail light, tripage fe & gas cap, r&g, ddm


DIY HID on/off switch with LED running lights: https://www.600rr.net/vb/showthread.php?t=150450
HighlyFavored0420 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-16-2010, 01:36 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
Check the power wire, it has probably just gone open circuit.
Nico is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome