05 Electrical Issues - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 10-11-2010, 02:26 PM Thread Starter
Training Wheel Hero
 
Join Date: Jul 2010
Location: SF Bay Area, California
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
05 Electrical Issues

I go to turn on my bike, which has been in the garage for about 3 weeks. It starts fine, except the speedometer/tachtometer and neutral light does not come on, so i cannot tell my speed or RPM's, also the turn signals do not work, nor the brake light. The headlights still work fine and it starts up normally so i assume it cannot be the battery. What could it be? Its an 05 600rr, and the fuel pump warms up when i turn the key as well.
SuperCBR is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-11-2010, 02:27 PM
Demented
Guest
 
Posts: n/a
Check your fuses.
post #3 of 7 (permalink) Old 10-11-2010, 02:28 PM
 
tripage's Avatar
 
Join Date: Jun 2004
Location: orlando
Posts: 14,330
Thanks: 598
Thanked 728 Times in 591 Posts
Feedback Score: 91 reviews
Fuse is blown. Replace it and enjoy..




http://tripageled.com/store/
Owner
Tristan Page
[email protected]
[email protected]
Dual low / Dual High beam led headlights. OEM appearance
http://tripageled.com/store/index.ph...product_id=236
Integrated Gear Indicator installed inside your cluster
http://tripageled.com/store/index.ph...product_id=116
tripage is offline  
 
post #4 of 7 (permalink) Old 10-11-2010, 02:46 PM Thread Starter
Training Wheel Hero
 
Join Date: Jul 2010
Location: SF Bay Area, California
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok thank you. How do i replace the fuse? Where is it located?
SuperCBR is offline  
post #5 of 7 (permalink) Old 10-11-2010, 02:47 PM Thread Starter
Training Wheel Hero
 
Join Date: Jul 2010
Location: SF Bay Area, California
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
better yet, ill use the search button, thanks!
SuperCBR is offline  
post #6 of 7 (permalink) Old 10-11-2010, 11:46 PM
AMA Supersport Racer
 
bullshat830's Avatar
 
Join Date: Jul 2008
Location: Oceanside, CA
Posts: 726
Thanks: 24
Thanked 6 Times in 3 Posts
Feedback Score: 4 reviews
just remove your left mids and there will be this little rubber box mounted on there if you havent found it yet!



'06 600RR
check out my build thread!
https://www.600rr.net/vb/showthread.php?t=181895


bullshat830 is offline  
post #7 of 7 (permalink) Old 10-11-2010, 11:56 PM Thread Starter
Training Wheel Hero
 
Join Date: Jul 2010
Location: SF Bay Area, California
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
cool thanks!
SuperCBR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome