05' High/low beam, horn switch unit loose - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 11-12-2010, 04:28 PM Thread Starter
Pocketbike Racer
 
LearningCurve's Avatar
 
Join Date: Aug 2010
Location: Oakboro, NC
Posts: 480
Thanks: 54
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
05' High/low beam, horn switch unit loose

I did a search came up with notta.

As the thread title reads, the deal that houses the high/low beam and horn switches is loose on the left clipon, sorry I don't know the technical term for it I come from the automotive world.

The deal has two screws in it now, tightening them did nothing, it does have a vacant all threaded hole where I'm sure something fell out of.

I know this is a simple issue I just need to know what kind of hardware fell out so I know what to look for. Pictures would be nice if available.

Thanks.
LearningCurve is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-12-2010, 05:07 PM
Pocketbike Racer
 
z537z's Avatar
 
Join Date: Jun 2010
Posts: 254
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 10 reviews
I'm pretty sure there's a hole that a piece of plastic drops into, to keep it from moving/rotating out of place.
There's just the 2 screws holding it together, pop it apart and see if there's a tab that's broken off in there.

__________________________________________

z537z is offline  
post #3 of 4 (permalink) Old 11-12-2010, 09:19 PM Thread Starter
Pocketbike Racer
 
LearningCurve's Avatar
 
Join Date: Aug 2010
Location: Oakboro, NC
Posts: 480
Thanks: 54
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
I'll do that, thanks.
LearningCurve is offline  
 
post #4 of 4 (permalink) Old 11-13-2010, 10:36 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by LearningCurve View Post
I did a search came up with notta.

As the thread title reads, the deal that houses the high/low beam and horn switches is loose on the left clipon, sorry I don't know the technical term for it I come from the automotive world.

The deal has two screws in it now, tightening them did nothing, it does have a vacant all threaded hole where I'm sure something fell out of.

I know this is a simple issue I just need to know what kind of hardware fell out so I know what to look for. Pictures would be nice if available.

Thanks.
can you post up a photo of the switch and the inside of the switch?
Nico is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome