Installed 08 ECU into 09 now FI light - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

Reply
 
LinkBack Thread Tools
post #1 of 39 (permalink) Old 01-22-2011, 07:36 PM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Installed 08 ECU into 09 now FI light

I installed the ecm from an 08 bike in order to get back my power which is lost on the 09. However after the bike starts, I get code 25 which the SM states is a knock sensor problem. I know I didn't go anywhere near the sensor so I don't know if this was just a stored code in the 08 ecu that was never cleared or what...I'm about to go back and try to clear the code with a jumper wire the DTC connector and see if the code flashes again. If that doesn't solve the problem, then I'm thinking it may be a bad ECM as I just started the bike with the 09 ECM right before taking her apart just to make sure everthing worked ok and no light. I will know if it's a problem with the 08 ECM if I connect the 09 ECM back and the FI light goes away. This is a non CA bike.

Ok, I just came back from clearing the MIL code. Switched back the 09 ECU and no code. Put in 08 ECU and code 25 again.

Any other ideas?

P.S
I hate 09 fairings

Last edited by Alloy; 01-23-2011 at 12:03 AM.
Alloy is offline  
Sponsored Links
Advertisement
 
post #2 of 39 (permalink) Old 01-23-2011, 12:44 AM
AMA Supersport Racer
 
Join Date: Aug 2007
Location: Sunnyvale
Posts: 541
Thanks: 1
Thanked 29 Times in 27 Posts
Feedback Score: 0 reviews
Try another 07/08 ecm.. sounds like you got a dud ecm.
post #3 of 39 (permalink) Old 01-23-2011, 02:23 AM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Damn. Not good...gotta deal with shipping and all that..but if that'll fix the problem then here we go...
Alloy is offline  
 
post #4 of 39 (permalink) Old 04-16-2011, 10:37 PM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
Don't know if your still having this same problem, but another bloke is and pointed me at your thread as well...

Here is your answer:


Quote:
Originally Posted by Nico View Post
Just looked it up for you and the knock sensor is wired differently...

A = Black connector
B = Light Grey connector

09:
Blue - B21
Blue/Yellow - B23
Yellow/Red - A9

08:
Blue - B21
Blue/Yellow - B5
Yellow/Red - A9

So wire it up the way it should be for an 08 ECU and you will be good to go!
Nico is offline  
post #5 of 39 (permalink) Old 04-17-2011, 03:01 AM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Nico,

thanks for the info. Not really sure how to use it as I'm not as mechnically inclined as I'd like to be. :(








Quote:
Originally Posted by Nico View Post
Don't know if your still having this same problem, but another bloke is and pointed me at your thread as well...

Here is your answer:
Alloy is offline  
post #6 of 39 (permalink) Old 04-17-2011, 03:03 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
Have a look at your light grey ecu plug, you just need to move the wire that is in pin 23 to pin 5, or if you have a decent bike shop they should be able to do it for you.
Nico is offline  
post #7 of 39 (permalink) Old 04-17-2011, 03:08 AM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Ok I can do that. Now what happens to the wire that is currently in pin 5? If there is one? I don't have the plug in front of me at this point. But I DO appreciate the help!!! I just rec'd a servo dummy plug that should help me lighten the bike some as well. So I'm exceited that I can finally get my lost HP back.
Alloy is offline  
post #8 of 39 (permalink) Old 04-17-2011, 03:15 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
You shouldn't be loosing any hp by having the dtc set, and there shouldn't be anything in pin 5 as far as I can tell...
Nico is offline  
post #9 of 39 (permalink) Old 04-17-2011, 03:20 AM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
I meant excited at the prospect of getting the 08 ecu finally working with my 09 bike due to your help :) I was wanting to do it in the 1st place to get back the lost HP that the 09 ecu had by replacing it with the 08 ecu. While I was at it, I had just bought servo plug to remove my exhaust servo motor and cables. Once I've conquered that, I was wanting to go into the airbox a bit. I think I also read something about a pair valve.
Alloy is offline  
post #10 of 39 (permalink) Old 07-10-2011, 10:59 PM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Nico View Post
You shouldn't be loosing any hp by having the dtc set, and there shouldn't be anything in pin 5 as far as I can tell...
Need quick help. Looking at grey connector, I can't tell which one is Pin 23. I know u mentioned blue/yellow wire but when trying to count the pins it doesn't count right. What color is pin #1? When trying to count from either side neither one equals pin 23 with blue yellow wire. If a solid blue wire is Pin 21, then pic 23 is black and yellow.

Last edited by Alloy; 07-11-2011 at 01:27 AM.
Alloy is offline  
post #11 of 39 (permalink) Old 07-10-2011, 11:12 PM
*BOTM Feb '11, Mar '12*
 
sincalirider's Avatar
 
Join Date: Aug 2008
Location: Visalia, Ca
Posts: 23,598
Thanks: 1,002
Thanked 1,191 Times in 901 Posts
Feedback Score: 27 reviews
Post a pic, it'll help someone point you in the right direction.

sincalirider is offline  
post #12 of 39 (permalink) Old 07-10-2011, 11:17 PM
Moto GP Racer
 
v-tec crx's Avatar
 
Join Date: Jun 2008
Location: Ottawa Canada
Posts: 7,428
Thanks: 288
Thanked 315 Times in 278 Posts
Feedback Score: 10 reviews
How much did you pay for the ecu?

I am from CANADA, the land of poutine, back-bacon and GOOD BEER!!
2012 STREET BIKE OF THE YEAR
v-tec crx is offline  
post #13 of 39 (permalink) Old 07-11-2011, 01:26 AM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
I got it from ebay from a place that sells used parts and I think I paid 60 plus shipping. Any how, see pics below and please advise.

Last edited by Alloy; 07-11-2011 at 01:46 AM.
Alloy is offline  
post #14 of 39 (permalink) Old 07-11-2011, 01:39 AM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Alloy is offline  
post #15 of 39 (permalink) Old 07-11-2011, 01:40 AM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
The solid blue one I believe was mentioned above to be B21. Can anyone tell me if you count across with the top left being #1 or if you count down by columns?


Last edited by Alloy; 07-11-2011 at 01:45 AM.
Alloy is offline  
post #16 of 39 (permalink) Old 07-11-2011, 02:22 AM
*BOTM Feb '11, Mar '12*
 
sincalirider's Avatar
 
Join Date: Aug 2008
Location: Visalia, Ca
Posts: 23,598
Thanks: 1,002
Thanked 1,191 Times in 901 Posts
Feedback Score: 27 reviews
Found this, maybe the images can help.

https://www.600rr.net/vb/showpost.php...61&postcount=6

sincalirider is offline  
post #17 of 39 (permalink) Old 07-11-2011, 03:59 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
This is the ECU side of the male connector....



Or in other words, take the wire in the circle and put it where the arrow is pointing...
(and yep, I realise that its black/yellow... that is my fault - misinterpreted Bl for Bu in the book)

Nico is offline  
The Following 4 Users Say Thank You to Nico For This Useful Post:
Alloy (07-13-2011), nutcore (08-18-2014), sincalirider (07-11-2011), topgd (06-01-2015)
post #18 of 39 (permalink) Old 07-11-2011, 04:08 AM
*BOTM Feb '11, Mar '12*
 
sincalirider's Avatar
 
Join Date: Aug 2008
Location: Visalia, Ca
Posts: 23,598
Thanks: 1,002
Thanked 1,191 Times in 901 Posts
Feedback Score: 27 reviews
No wonder I couldn't figure out the wiring scheme. Lol

Good post Nico

sincalirider is offline  
post #19 of 39 (permalink) Old 07-11-2011, 04:12 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
haha yep, my bad...
Nico is offline  
post #20 of 39 (permalink) Old 07-11-2011, 09:21 AM Thread Starter
Knee Dragger
 
Join Date: May 2010
Posts: 220
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
OMG thanks!
Alloy is offline  
post #21 of 39 (permalink) Old 07-11-2011, 11:12 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
No worries mate.
Nico is offline  
post #22 of 39 (permalink) Old 02-13-2012, 12:05 PM
World Superbike Racer
 
ProWakeskater's Avatar
 
Join Date: Nov 2008
Posts: 1,635
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 4 reviews
thank you for this info!
ProWakeskater is offline  
post #23 of 39 (permalink) Old 02-14-2012, 02:08 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
No worries mate.
Nico is offline  
post #24 of 39 (permalink) Old 10-27-2012, 10:37 PM
AMA Supersport Racer
 
Join Date: Jun 2012
Location: Orlando, Florida
Posts: 1,017
Thanks: 117
Thanked 58 Times in 50 Posts
Feedback Score: 8 reviews
Thanks

Just bought an 09 ECU for my 07 today. I'd rather have an 07 or 08 but I need my baby back and this was the only one I could afford. $53.83 total after tax picked up was a good deal.

Just wanna say Thanks to you Nico for helping out once again, I am hoping all I need to do is reverse the order that you stated above and all will be well.

Switch Light Grey Connector's B5 (Black/Yellow) to Light Grey Connector's B23 (empty) and presto!

I will be attempting this first thing in the morning so figers crossed everything goes well first of all and second fingers crossed that the ECU is indeed my problem..

I wont be gettin much sleep tonight...I just want the morning to come because the anticipation is killing me lol
SlowREV69 is offline  
post #25 of 39 (permalink) Old 10-28-2012, 06:23 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
Yep, just gotta go back the other way...
Nico is offline  
post #26 of 39 (permalink) Old 10-28-2012, 11:58 PM
AMA Supersport Racer
 
Join Date: Jun 2012
Location: Orlando, Florida
Posts: 1,017
Thanks: 117
Thanked 58 Times in 50 Posts
Feedback Score: 8 reviews
Okay so I switched the wires and I got the code 25 too lol, I am going to switch them back the way they were and see if that solves it tomorrow..it makes sense to just do the reverse when switching from an 07 to an 09 but maybe it doesnt need to be switched..ill keep yall updated
SlowREV69 is offline  
post #27 of 39 (permalink) Old 03-07-2013, 03:33 PM
Pocketbike Racer
 
Ecko508's Avatar
 
Join Date: Jul 2011
Location: Boston, MA
Posts: 415
Thanks: 1
Thanked 15 Times in 14 Posts
Feedback Score: 9 reviews
I just did this to my 09 today..of course the wire got frayed and snapped when I tried to pull it out. Luckily I have experience with electrical connectors and just redid the connection to the pin. No check engine light after the ECU and pin switch but only time will tell as I can't ride because of the winter. Anyone have any issues with it??
Ecko508 is offline  
post #28 of 39 (permalink) Old 07-25-2013, 08:30 AM
Moto GP Racer
 
crashkhanman's Avatar
 
Join Date: Mar 2008
Location: Charlotte, NC 28217
Posts: 3,968
Thanks: 449
Thanked 331 Times in 285 Posts
Feedback Score: 9 reviews
Bump for popular topic.

'07 CBR600RR Track-Only Demon!
Nesba/N2/PRE/TPM/Roger Lyle "A" Group // CCS #306

'08 GSXR 600 Blue ~ Current Bike
'07 Yamaha R6 Blue ~ SOLD
'08 CBR600RR Silver ~ SOLD
'06 Yamaha R6 Black ~ SOLD
'08 GSXR 600 TrackOnly ~ SOLD
'08 GSXR 600 White ~ SOLD
'08 Yamaha R6 ~ SOLD
'07 GSXR 750 ~ SOLD
'12 Aprilia RSV4 Factory ~ Crashed/SOLD
'07 CBR600RR Black ~ SOLD
'09 CBR600RR Phoenix TrackOnly ~SOLD
'09 CBR600RR Red/Black ~SOLD
'07 CBR600RR Blue/Silver ~SOLD
crashkhanman is offline  
post #29 of 39 (permalink) Old 07-25-2013, 11:22 AM
Knee Dragger
 
Join Date: Oct 2012
Posts: 111
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Good thread/Great info!
Ruscbr is offline  
post #30 of 39 (permalink) Old 08-27-2013, 09:40 PM
Knee Dragger
 
Join Date: Oct 2012
Posts: 111
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
I wanna know how you guys took the wire out of that connector

2008 Honda CBR600RR "Silver Bullet"
2009 Honda CBR600RR "To Punish & Ensalve"
Ruscbr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome