Horn doesn't work - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 01-23-2011, 12:07 PM Thread Starter
Training Wheel Hero
 
Join Date: Dec 2010
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Horn doesn't work

Is it more likely that my horn is shot or my horn switch? Cause right now my horn doesn't work and it's on an 06 600rr
edogg6565 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-23-2011, 12:13 PM
 
tripage's Avatar
 
Join Date: Jun 2004
Location: orlando
Posts: 14,330
Thanks: 598
Thanked 728 Times in 591 Posts
Feedback Score: 91 reviews
Remove the connections on the horn itself and clean them.. If they get dirty will cause the horn to not work. T




http://tripageled.com/store/
Owner
Tristan Page
[email protected]
[email protected]
Dual low / Dual High beam led headlights. OEM appearance
http://tripageled.com/store/index.ph...product_id=236
Integrated Gear Indicator installed inside your cluster
http://tripageled.com/store/index.ph...product_id=116
tripage is offline  
post #3 of 5 (permalink) Old 01-23-2011, 01:45 PM
Training Wheel Hero
 
hova32169's Avatar
 
Join Date: Sep 2007
Location: San Fernando Valley
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Try tightening the connections at the horn with a pair of pliers. One of mine used to come off and I had to do this.
hova32169 is offline  
 
post #4 of 5 (permalink) Old 01-23-2011, 01:48 PM Thread Starter
Training Wheel Hero
 
Join Date: Dec 2010
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Will do. Thanks again for the help
edogg6565 is offline  
post #5 of 5 (permalink) Old 01-23-2011, 04:27 PM
Moto GP Racer
 
03cbr-rider's Avatar
 
Join Date: May 2010
Location: Upstate, NY
Posts: 5,702
Thanks: 213
Thanked 605 Times in 479 Posts
Feedback Score: 2 reviews
if you're ever having trouble finding out whether the horn is shot, just get a voltmeter and test for voltage. if your horn is shot, most any 12 volt horn will work. most of them are just two connections for the positive and negative or ground wire.
03cbr-rider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome