2008 600 Fuel Injector issues (Code 16) - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 02-15-2011, 07:37 PM Thread Starter
Training Wheel Hero
 
Join Date: Aug 2008
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2008 600 Fuel Injector issues (Code 16)

I'm receiving error code 16 with my bike. When I accelerate hard on the bike, it turns off. The error code text says "#1 Secondary injector circuit malfunction". Clearly this is related to the #1 secondary injector, but I'm not 100% sure for the following reasons:

1. I am running the Bazzaz Z-FI tuner. I called bazzaz, and he suggested checking the plugs on the harness because they could have come loose. I'm hoping to avoid this step because lifting the tank is a pain. I will do it this weekend if I am told there is no other way.

2. Prior to the bike acting up, I left it sitting for probably 5 months without riding and without prepping it to sit unused for a long time.

Steps I have taken before I actually learned about getting the code read out:

1. Changed the Oil (synthetic)
2. Changed the spark plugs
3. New tank of gas.
4. Bottle of fuel injector cleaner. I doubt this actually helped anything because the bike shuts off the moment the secondary injector kicks in, so it never got to clean the affected injectors.

Any suggestions on the next steps? Anyone have any idea how likely my fuel injector is to be fouled up vs. the bazzaz unit going faulty? How do you even try to clean the secondary fuel injectors if they are clogged? Should I just take it to the dealership and pay an arm and a leg for them to look at it (I'm out of warranty).
Andy6387 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-15-2011, 07:45 PM
Moto GP Racer
 
tenjin's Avatar
 
Join Date: Mar 2008
Location: Phoenix, AZ
Posts: 8,768
Thanks: 36
Thanked 367 Times in 258 Posts
Feedback Score: 4 reviews
my money is on a loose plug.

and its not big of a pain, would take me maybe 5 minutes to get the tank back


DDM 55w 7k HID
Sliders
Black Vortex Rearsets
R&G Bar Ends
Black passenger pegs
JPR Shorty levers
Drive Systems Superlight rear sprocket +2
Drive systems front sprocket -1
EK 520MVXZ black chain
Arata Ti Slipon with Ti mid pipe
Pro-Bolts black fairing bolt kit
Versah RJL Brake pads
Flushmounts
fender eliminator
Pair Delete
Bazzaz AFM

tenjin is offline  
post #3 of 3 (permalink) Old 02-16-2011, 04:32 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
Loose plug, or bazzaz issues... check the plug first
Nico is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome