Help!! Engine Doesn't Rev Up - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 04-30-2011, 10:22 AM Thread Starter
Knee Dragger
 
max600racing's Avatar
 
Join Date: Mar 2010
Posts: 130
Images: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Help!! Engine Doesn't Rev Up

Just finished to install a HRC Power Up Kit and re-assemble the engine and all the harness/wiring. After I bring the engine to working temperature and try to rev it, the engine is unable to rev up and the it stuck around 2500rpm. Do you guys have any idea of what is happening? Is it a electrical or mechanical problem? Thanks in advance.

The bike is equipped with HRC harness and ECU so the idling is set to 2500rpm. I have a PCV and autotune installed but the PCV has zero map and currectly disable the autotune.

http://s1028.photobucket.com/albums/..._3224_x264.mp4
max600racing is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-30-2011, 10:57 AM
AMA Supersport Racer
 
Tyleronanrr's Avatar
 
Join Date: Jan 2010
Location: Gainesville,FL
Posts: 666
Images: 2
Thanks: 6
Thanked 31 Times in 29 Posts
Feedback Score: 0 reviews
i dont know a whole lot about the hrc kits but i have heard that a power comander wont work with the hrc ecu. so my advice would be to disconnect the power comander and try again. i am going to assume you are sure your throttle wires and throttle bodies were all assembled correctly though.
Tyleronanrr is offline  
post #3 of 4 (permalink) Old 04-30-2011, 11:18 AM Thread Starter
Knee Dragger
 
max600racing's Avatar
 
Join Date: Mar 2010
Posts: 130
Images: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm sure the powercommander can be worked with the HRC ECU because that's the way I used for a year long. However, I would try to replace it with a stock ECU first to see what happen. If the syptom persists, I will take away the PCV, ignition module and Autotune.

Any other thoughts?
max600racing is offline  
 
post #4 of 4 (permalink) Old 04-30-2011, 12:20 PM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
Sounds like its cutting the ignition, would you happen to have a quick shifter installed as well? I would start by unplugging that first up...

Does the HRC ECU have an adjustable rev limiter? If so what's that set to?

I don't know a lot about HRC stuff other than its to damn expensive...
Nico is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome