Need help with flush mounts - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 05-29-2011, 11:49 AM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2011
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need help with flush mounts

I recently laid my bike down and broke off both OEM front turn signals, now after I fixed the bike back up my flush mounts wont even flash. I double checked the wiring and its right any other ideas to what is the problem?
bmurphy1978 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-29-2011, 11:56 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
You need either an LED relay or load resistors if none of them flash (front and rear), otherwise you have wired something incorrectly.

What year is your bike?
Nico is offline  
post #3 of 4 (permalink) Old 05-29-2011, 11:59 AM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2011
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Its an 05 and the rear works normal
bmurphy1978 is offline  
 
post #4 of 4 (permalink) Old 05-29-2011, 12:07 PM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
In that case you have more than likely wired it up wrong...

There are three wires going to each signal (assuming you are in the states) which ones have you wired up to?
Nico is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome