Front brakes buzzing after new pads - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 05-08-2012, 11:44 AM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Front brakes buzzing after new pads

I just recently replaced the front brake pads (both calipers) with new EBC pads. I can hear a buzzing coming from the front. It sounds like a mosquito flying around near your ear.

The buzzing is stronger as speed is higher, and it only happens when i apply brakes normally. If I stop hard or very lightly, it doesn't happen. Any thoughts?
FurbiesAndBeans is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-09-2012, 02:57 AM
Pocketbike Racer
 
Join Date: Apr 2012
Posts: 347
Thanks: 47
Thanked 46 Times in 41 Posts
Feedback Score: 2 reviews
Did you get the EBC HH?

If so, the noise is normal and the tone will lower after the pads have been bedded to the rotors.

The EBC HH's are my favorite pads so I'm used to hearing that noise on 3 of my bikes =)

Just so long as you've still got good bite and no fade, it's a typical noise.
oldschooldesigns is offline  
post #3 of 5 (permalink) Old 05-09-2012, 04:00 AM
AMA Supersport Racer
 
Join Date: Jan 2009
Posts: 697
Thanks: 14
Thanked 25 Times in 18 Posts
Feedback Score: 4 reviews
Thats normal. When I went from stock to Carbone Lorraine SBK5 pads I heard the same buzzing noise. Sometime after that, I never really know when, it went away.

But just to be sure I double checked that all the bolts were torqued properly, after doing that I just rode it til they "bedded" in and the buzzing went away.

Did you do prep the rotors in any way, or did you just take the old pads out and pop in the new pads?
socal_cbr is offline  
 
post #4 of 5 (permalink) Old 05-09-2012, 11:42 AM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by oldschooldesigns View Post
Did you get the EBC HH?

If so, the noise is normal and the tone will lower after the pads have been bedded to the rotors.

The EBC HH's are my favorite pads so I'm used to hearing that noise on 3 of my bikes =)

Just so long as you've still got good bite and no fade, it's a typical noise.
Yes I got the HHs. Got the 4 pads for 40

Only ridden them about 100 miles, they have brake hard so no complains here. I'll wait until the sound goes away then.
FurbiesAndBeans is offline  
post #5 of 5 (permalink) Old 05-09-2012, 11:43 AM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by socal_cbr View Post
Thats normal. When I went from stock to Carbone Lorraine SBK5 pads I heard the same buzzing noise. Sometime after that, I never really know when, it went away.

But just to be sure I double checked that all the bolts were torqued properly, after doing that I just rode it til they "bedded" in and the buzzing went away.

Did you do prep the rotors in any way, or did you just take the old pads out and pop in the new pads?
Thanks for the info. I didn't prep them at all. Took out the old ones, cleaned up the calipers a bit, and put the new ones in.
FurbiesAndBeans is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome