HID on/off sporadically - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 05-16-2012, 08:00 PM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2012
Posts: 60
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
HID on/off sporadically

My HID low beam sometimes doesn't turn on. When I turn the ignition on the bulb always flashes, sometimes it stays on.

Faulty ballast?
Dr. Rockwell is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-16-2012, 08:24 PM
*BOTM Feb '11, Mar '12*
 
sincalirider's Avatar
 
Join Date: Aug 2008
Location: Visalia, Ca
Posts: 23,598
Thanks: 1,002
Thanked 1,191 Times in 901 Posts
Feedback Score: 27 reviews
How is the high beam? Same thing or not? Did you recently do any mods to your electrical system? If the High beam side is ok, try switching the ballasts. The lower priced HID ballast are known to flicker after some time.

sincalirider is offline  
post #3 of 9 (permalink) Old 05-16-2012, 09:58 PM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2012
Posts: 60
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
High beam is fine. Haven't done any electrical mods.

Not sure what kind of HID kit the bike has (modded by previous owner). Can replacement ballasts be easily sourced?
Dr. Rockwell is offline  
 
post #4 of 9 (permalink) Old 05-16-2012, 11:04 PM
*BOTM Feb '11, Mar '12*
 
sincalirider's Avatar
 
Join Date: Aug 2008
Location: Visalia, Ca
Posts: 23,598
Thanks: 1,002
Thanked 1,191 Times in 901 Posts
Feedback Score: 27 reviews
Quote:
Originally Posted by Dr. Rockwell View Post
High beam is fine. Haven't done any electrical mods.

Not sure what kind of HID kit the bike has (modded by previous owner). Can replacement ballasts be easily sourced?
Yeah, pretty easily and cheaply once you identify them.

sincalirider is offline  
post #5 of 9 (permalink) Old 05-17-2012, 07:42 PM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2012
Posts: 60
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
It's a MaxCarr brand ballast. I can't find replacements of this unit online. Any suggestions?
Dr. Rockwell is offline  
post #6 of 9 (permalink) Old 05-17-2012, 08:15 PM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2012
Posts: 60
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
I haven't had a chance to swap ballasts for a test yet. The Low beam ballast doesn't fire up at all. Could there be a wiring/connection issue that would affect the low beam without affecting any other electrical system?
Dr. Rockwell is offline  
post #7 of 9 (permalink) Old 05-17-2012, 08:54 PM
*BOTM Feb '11, Mar '12*
 
sincalirider's Avatar
 
Join Date: Aug 2008
Location: Visalia, Ca
Posts: 23,598
Thanks: 1,002
Thanked 1,191 Times in 901 Posts
Feedback Score: 27 reviews
Without taking a multimeter to it, it'll be hard to pin point. Try the easy stuff first. Test the OEM plug for power, check fuses, etc.

sincalirider is offline  
post #8 of 9 (permalink) Old 05-30-2012, 01:26 PM
AMA Supersport Racer
 
Join Date: Mar 2012
Location: NYC
Posts: 1,075
Thanks: 0
Thanked 36 Times in 34 Posts
Feedback Score: 0 reviews
the easy thing to do is just swap the ballasts. you can find out where the problem lies. you can always just buy a new kit and then just swap out the ballasts.
kingnba6 is offline  
post #9 of 9 (permalink) Old 05-30-2012, 01:30 PM
Moto GP Racer
 
Neptune's Avatar
 
Join Date: Sep 2011
Location: Long Beach, CA
Posts: 8,155
Thanks: 338
Thanked 663 Times in 569 Posts
Feedback Score: 4 reviews
anytime i read a thread about faulty headlights i think of this thread here:

https://www.600rr.net/vb/showthread.php?t=138034

give it a go and see if thats the problem. doesnt take much to open up the housing and its very easy do put back together.

Drift Camera Forum - http://driftcamforum.com/
Neptune is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome