Feels weak help. - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 06-03-2012, 02:09 PM Thread Starter
Knee Dragger
 
fuzion24's Avatar
 
Join Date: Jan 2012
Location: Grand Forks, ND
Posts: 249
Thanks: 5
Thanked 21 Times in 19 Posts
Feedback Score: 0 reviews
Feels weak help.

I have an 08 with 9000miles. Just changed the oil about 500 miles ago with T6 an cleaned and lubed chain at the same time as well as a coolant flush. I feel that i have lost power in my 1st and it's starting to feel that I am losing power in second. Don't get me wrong it still pulls but just not like it has. What could possibly be the cause of this. What should I check to to find out if something is wrong or if I am just imagining it. Could it be the clutch slipping or a bad plug. I was also think maybe something is up with the gears or a fuel injectors. I just don't want to take it in to get it heckled out and spend money that could be spent else where just for them to tell me I am crazy. Thanks in advance for the advice.
fuzion24 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-03-2012, 05:23 PM
Moto GP Racer
 
tenjin's Avatar
 
Join Date: Mar 2008
Location: Phoenix, AZ
Posts: 8,768
Thanks: 36
Thanked 367 Times in 258 Posts
Feedback Score: 4 reviews
doubt you are getting power loss on a per gear basis.... dunno tho.


DDM 55w 7k HID
Sliders
Black Vortex Rearsets
R&G Bar Ends
Black passenger pegs
JPR Shorty levers
Drive Systems Superlight rear sprocket +2
Drive systems front sprocket -1
EK 520MVXZ black chain
Arata Ti Slipon with Ti mid pipe
Pro-Bolts black fairing bolt kit
Versah RJL Brake pads
Flushmounts
fender eliminator
Pair Delete
Bazzaz AFM

tenjin is offline  
post #3 of 3 (permalink) Old 06-03-2012, 07:15 PM
World Superbike Racer
 
speeddeamon88's Avatar
 
Join Date: Apr 2012
Posts: 1,583
Thanks: 222
Thanked 101 Times in 91 Posts
Feedback Score: 0 reviews
doubt you are unless your chain is got more slack in it since then.? Mine had too much and i tightened it up to specs and made a huge difference in grab. Or you can drain your fluids and check for metal particals if you think it is gears

MachineGunMyers - Xbox gamertag
The X's #1 Fan™
speeddeamon88 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome