Installed PCV now fuel pump wont prime - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 06-18-2012, 12:19 PM Thread Starter
Pocketbike Racer
 
Join Date: Feb 2012
Location: Sumter
Posts: 253
Thanks: 14
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Installed PCV now fuel pump wont prime

I can hear the relay tick but that's it. Its a 2011 CBR600RR. It will turn over but wont start. With everything turned off. I turn the key to on. The flip the kill switch and normally hear the fuel pump prime. All I hear is the relay tick by the fuse box. All fuses are good, all connections are good. I did plug into the fuel injectors up under the gas tank not the ones on top of the air box. So I did remove the entire fuel tank. Any thoughts or advice?

Sent from my DROIDX using Motorcycle.com Free App
thewakka1 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 06-18-2012, 12:43 PM
BOTM Winner 07/12
 
03WisconsinRR's Avatar
 
Join Date: Jun 2005
Location: Wisconsin
Posts: 1,714
Images: 8
Thanks: 66
Thanked 131 Times in 109 Posts
Garage
Feedback Score: 17 reviews
Make sure the PC is getting power and the lights are on.

08'RR
Akra Evo TI - Bazzaz ZfiTc - Acumen Gear Indicator - Yoyo Stay - Keyless Mod - Michelin Power Cup - HRC overflow - ECUnleashed
Yoyo Slipper - Galfer Lines - HRC Rear Res - HRC Throttle - Woodcraft Sliders - Woodcraft Rearsets - Servo Mod - Samco Hoses
BMC - Hotbodies - Brembo RCS19 - Penske 8987 & 20mm Valving - ASV Levers - Rk 520 - GPR Damper - EBC XC Rotors
Woodcraft Clipons - Gilles Chain Adjuster - R&R Subframe - PAIR Mod - Cox Rad Guard - MOYT 4 cell - Factory Pro Shift Star
03WisconsinRR is offline  
post #3 of 10 (permalink) Old 06-18-2012, 01:57 PM Thread Starter
Pocketbike Racer
 
Join Date: Feb 2012
Location: Sumter
Posts: 253
Thanks: 14
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Were does the pc get power from?

Sent from my DROIDX using Motorcycle.com Free App
thewakka1 is offline  
 
post #4 of 10 (permalink) Old 06-18-2012, 02:04 PM
BOTM Winner 07/12
 
03WisconsinRR's Avatar
 
Join Date: Jun 2005
Location: Wisconsin
Posts: 1,714
Images: 8
Thanks: 66
Thanked 131 Times in 109 Posts
Garage
Feedback Score: 17 reviews
Dont quote me but I think the PC gets power from one or more of the piggy back plugs, like the injector plugs. The Bazzaz still splices into a wire to get power/signal.

08'RR
Akra Evo TI - Bazzaz ZfiTc - Acumen Gear Indicator - Yoyo Stay - Keyless Mod - Michelin Power Cup - HRC overflow - ECUnleashed
Yoyo Slipper - Galfer Lines - HRC Rear Res - HRC Throttle - Woodcraft Sliders - Woodcraft Rearsets - Servo Mod - Samco Hoses
BMC - Hotbodies - Brembo RCS19 - Penske 8987 & 20mm Valving - ASV Levers - Rk 520 - GPR Damper - EBC XC Rotors
Woodcraft Clipons - Gilles Chain Adjuster - R&R Subframe - PAIR Mod - Cox Rad Guard - MOYT 4 cell - Factory Pro Shift Star
03WisconsinRR is offline  
post #5 of 10 (permalink) Old 06-18-2012, 02:46 PM Thread Starter
Pocketbike Racer
 
Join Date: Feb 2012
Location: Sumter
Posts: 253
Thanks: 14
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
I will check for lights on it when I get home. There wasn't a power wire. It must get it from the injector or TPS. But why would any of the keep the fuel pump from priming?

Sent from my DROIDX using Motorcycle.com Free App
thewakka1 is offline  
post #6 of 10 (permalink) Old 06-18-2012, 02:54 PM
BOTM Winner 07/12
 
03WisconsinRR's Avatar
 
Join Date: Jun 2005
Location: Wisconsin
Posts: 1,714
Images: 8
Thanks: 66
Thanked 131 Times in 109 Posts
Garage
Feedback Score: 17 reviews
That happened with my bazzaz. The splice for power was so-so and every once in a while it would not signal.

08'RR
Akra Evo TI - Bazzaz ZfiTc - Acumen Gear Indicator - Yoyo Stay - Keyless Mod - Michelin Power Cup - HRC overflow - ECUnleashed
Yoyo Slipper - Galfer Lines - HRC Rear Res - HRC Throttle - Woodcraft Sliders - Woodcraft Rearsets - Servo Mod - Samco Hoses
BMC - Hotbodies - Brembo RCS19 - Penske 8987 & 20mm Valving - ASV Levers - Rk 520 - GPR Damper - EBC XC Rotors
Woodcraft Clipons - Gilles Chain Adjuster - R&R Subframe - PAIR Mod - Cox Rad Guard - MOYT 4 cell - Factory Pro Shift Star
03WisconsinRR is offline  
post #7 of 10 (permalink) Old 06-18-2012, 03:05 PM
Lifetime Premium
 
BLACK ICE RR's Avatar
 
Join Date: Mar 2009
Location: Salt Lake City, Utah
Posts: 586
Thanks: 2
Thanked 14 Times in 14 Posts
Feedback Score: 2 reviews
I am having this same problem PCV does not have power light on.

2005 CBR 600RR Tribal
Pinebox custom exhaust + header
PCv + pair mod
Ape CCT
Vortex Clip-ons
MOTY battery
ZG DB
Milled rear rotor
55w HIDs
Rear res delete mod
flush mounts, frame sliders

Get outta here troll!
BLACK ICE RR is offline  
post #8 of 10 (permalink) Old 06-18-2012, 03:22 PM
Knee Dragger
 
Joe81's Avatar
 
Join Date: Oct 2008
Location: South Florida
Posts: 242
Thanks: 5
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
Re-check all of your connections, check your fuses.. It may be a bad pcv...

Joe81 is offline  
post #9 of 10 (permalink) Old 06-18-2012, 09:45 PM Thread Starter
Pocketbike Racer
 
Join Date: Feb 2012
Location: Sumter
Posts: 253
Thanks: 14
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
It turned out to be a bad ground, I believe. I replaced the connecters for the grounds and it started right up. All in all it took about 3 hours of work to install the PCV with the IRC. Man what a difference. Thanks for the all the quick replies. Next up will be the headers and auto tune.
thewakka1 is offline  
post #10 of 10 (permalink) Old 06-22-2012, 07:23 PM
Lifetime Premium
 
BLACK ICE RR's Avatar
 
Join Date: Mar 2009
Location: Salt Lake City, Utah
Posts: 586
Thanks: 2
Thanked 14 Times in 14 Posts
Feedback Score: 2 reviews
Glad you got it figured out. Mine turned out to be gunk built up in killswitch. Symptoms were: starter worked, no lights on PCV, no fuel delivery. Checked relays, checked grounds. Hope this helps other people. It was an easy thing to check and an easy fix.

2005 CBR 600RR Tribal
Pinebox custom exhaust + header
PCv + pair mod
Ape CCT
Vortex Clip-ons
MOTY battery
ZG DB
Milled rear rotor
55w HIDs
Rear res delete mod
flush mounts, frame sliders

Get outta here troll!
BLACK ICE RR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome