Trouble installing Speedo Healer 07 CBR - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 09-22-2012, 12:56 AM Thread Starter
Training Wheel Hero
 
Join Date: May 2011
Location: Las Vegas
Posts: 91
Thanks: 3
Thanked 8 Times in 5 Posts
Feedback Score: 0 reviews
Question Trouble installing Speedo Healer 07 CBR

Hi all,

I just got my speedo healer (took me a couple months to finally get around to buying it).

I started working on it earlier tonight and have gotten stuck. There might be a few places where i might be going wrong.

I got the correct harness (SH-HO5 for the 2007 CBR600RR) and SpeedoHealer v4


I went ahead and removed the Speed Sensor coupler and even did the "Confirmation" that comes with the paper "Install Guide for SH-H05 Harness Kit"

I disconnected it and then followed: "Rotate the rear wheel while the ignition is on. Does the speedometer show 0, turn the ignition off and proceed to the next step" I even tested it before and had the ignition on and spun the wheel with my hand and the speedometer started to read it. So i know that i disconnected the Speed Sensor.

Are both connectors supposed to be connected? It is a bit unclear. So far i connect one connecter from the harness and then connect the other end of the harness to the Speedo Healer box. Should one of the connectors not be left unconnected? (refer to the picture above) I tried it by connecting both and nothing. When i go to test whether it is installed properly following these instructions:

"1. Have the ignition off 2. Pres SEL and keep it depressed while you turn ignition ON [t] (test) is now indicated. Release the button"

The speedohealer never turns on or shows me a t. The digit screen remains off. What am i missing?

If anything is unclear please let me know! My bike is in my garage right now taken apart awaiting the help of 600rr.net!

Sincerely,
A and noob!
pyrokrft is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-28-2018, 11:24 PM
Training Wheel Hero
 
Join Date: Jun 2018
Location: Beaverton, OR
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm new to bikes, i have a 07' cbr600rr. changed my sprockets and chain to -1/+2 and 520 chain so a speeadohealer is required. bought the exact same SH. I have no idea what to do as well, same question, the extra wire, where does it go?
I'm hoping someone on here has a clue what to do.

Thanks,
Dan
huynh.dan is offline  
post #3 of 4 (permalink) Old 06-29-2018, 03:56 PM
Training Wheel Hero
 
Join Date: Oct 2017
Posts: 34
Thanks: 48
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
So I have a 08 model and used a SpeedoHealer. What you do is you connect one end to the bike from the little box and then you connect the other end to the sensor. So basically it acts as a jumper in between the two wires. Hope this helps. All it does is mess with the Speedometer and tricks it into thinking its going slower (or vice versa) so that your sensors and everything will be accurate. Hope this helps. I didn't do the 520 but I did do the sprocket swap for the torque.
bmac7599 is offline  
 
post #4 of 4 (permalink) Old 07-01-2018, 03:01 AM
Training Wheel Hero
 
Join Date: Jun 2018
Location: Beaverton, OR
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hey bmac7599. i uploaded a photo of the wires. there's 3. would you happen to know where to plug them into?
One goes into the SH, one goes into the speedometer sensor. where does the other go?
Attached Thumbnails
Click image for larger version

Name:	IMG_9589.jpg
Views:	42
Size:	83.2 KB
ID:	199629  
huynh.dan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome