06 cbr600rr gauge cluster/taillight fuse keeps blowing - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 09-24-2012, 11:32 PM Thread Starter
Training Wheel Hero
 
didly's Avatar
 
Join Date: Jul 2009
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
06 cbr600rr gauge cluster/taillight fuse keeps blowing

Hey everyone I'm in a real jam..
My tail light and gauge cluster stopped working a few months back.
It happened literally after I washed my bike.
Every time I put a fuse in it blows...
It literally will not even light the tail light up before it pops..
Right now I have the front cowl off and gauge cluster is disconnected and I'm still blowing the fuse.
How do I pinpoint the possible short ??
I have work in the morning and have to leave at 5 am..(dark)
And don't wanna be pulled over or hit...
I would have thought that 6 months later there wouldn't be any water anymore and it wouldn't keep popping..
But that's not the case..
I know I'm asking last second but if anyone has time to lend a guy some advice tonight id much appreciate it..
didly is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-26-2012, 12:30 AM
Lifetime Premium
 
pumpkinHED's Avatar
 
Join Date: Oct 2011
Location: philadelphia
Posts: 56
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
remove fairings check ALL connectors make sure theyre clean, add some dielectric grease. double check grounds and make sure they're clean and tight. has this had any electrical work/mods done to it or is it 100% stock?
pumpkinHED is offline  
post #3 of 3 (permalink) Old 09-26-2012, 12:32 AM
Lifetime Premium
 
pumpkinHED's Avatar
 
Join Date: Oct 2011
Location: philadelphia
Posts: 56
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
pumpkinHED is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome