08 turn signal fuse blowing - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 10-21-2012, 07:12 PM Thread Starter
Training Wheel Hero
 
foxhonda554's Avatar
 
Join Date: Sep 2008
Location: kcmo
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
08 turn signal fuse blowing

i have been reading any thread i can find and cant find the same. i havent done anything to it recently and all the sudden the turn signal fuze keeping blowing as soon as i turn the key on. i have unhooked all the turn signals, the turn signal switch, the signal relay and it still keeps blowing just as soon as i turn on the key. i have traced the harness down for any open wires and touching wires and nothing. could it be something else in the ignition , or the ignition switch , or something????? dont know what else to try. PLEASE HELP Thanks

2008 CBR600RR ORANGE
foxhonda554 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome