coolant system problems - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 01-14-2013, 05:43 PM Thread Starter
Training Wheel Hero
 
JBDdsmer610's Avatar
 
Join Date: Jun 2011
Location: Easton, PA
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Smile coolant system problems

ok so i ride my bike year round. i had it sittring for like 3 weeks then it got freezing cold out.since then for some reason i am pushing fluid out of my rad cap. i bought a bran new cap from honda threw it on today and rode home. got off and took a look and its still leaking and i dont kno where to start now....any suggestions

-Jardine RT-1 slip on chopped 2in
-K&N filter
-Vortex sprockets 15/45
-RK GB520 chain
-Healtech speedo healer
-RideitMoto shorty levers
-Hot bodies flush mount blinkers
-PSR 2up Bar and PSR Pegs
-Sick HID's licence plate light
-Zero gravity Double bubble,
-Black probolt fairing kit
JBDdsmer610 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome