tach doesnt work? - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 01-22-2013, 01:57 AM Thread Starter
Knee Dragger
 
thekw's Avatar
 
Join Date: Apr 2012
Posts: 194
Thanks: 13
Thanked 5 Times in 5 Posts
Feedback Score: 2 reviews
tach doesnt work?

So my friend is having a problem and his tach doesnt work. What could be the reasons? and how can it be fixed?

thanks guys



Orange Tribal
-Leo Vince SBK
-DDM hid hi/lo
-the2wheels.com shorty levers
-Galfer wave rotors and breaks
-Progrip rim tape
-Progrip tank cap protector
-Progrip tank protector
-Aftermarket front blinkers
-OPP carbon fiber clutch cover
-OPP carbon fiber motor cover
-Side plate mount
-Double bubble smoked windscreen
-Shorai battery
-Integrated tail light
thekw is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 01-22-2013, 02:04 AM
Ldn
World Superbike Racer
 
Ldn's Avatar
 
Join Date: Nov 2012
Posts: 2,061
Thanks: 26
Thanked 334 Times in 273 Posts
Feedback Score: 4 reviews
tach doesnt work?

Have you done any troubleshooting yet? Checked fuses, connections, is the bike on?


Sent from my iPhone using Motorcycle.com Free App

"I don't want to burden you with my problems... but I think I've outgrown my yacht."

:)
Ldn is offline  
post #3 of 11 (permalink) Old 01-22-2013, 02:08 AM
World Superbike Racer
 
Gashuffer's Avatar
 
Join Date: Oct 2009
Location: Chicago Burbs
Posts: 1,718
Thanks: 96
Thanked 93 Times in 87 Posts
Feedback Score: 5 reviews
tach doesnt work?

Has he had the bike apart lately? Maybe unplugged the plug in the back of the display?


Sent from my Motorcycle.com App

Give a man a fish; you have fed him for today. Teach a man to fish; and you have fed him for a lifetime.
Gashuffer is offline  
 
post #4 of 11 (permalink) Old 01-22-2013, 02:20 AM
clx
World Superbike Racer
 
Join Date: Sep 2011
Location: Gauteng, South Africa
Posts: 1,628
Thanks: 92
Thanked 174 Times in 124 Posts
Feedback Score: 0 reviews
try turning the key. if that doesnt work make sure the bike is in neutral, the red switch is in the ON position, then turn the key again. still nothing?

ok i know im not funny (was gonna reccoment checking the fuel but ill probably be beaten to a pulp by then)

The tacho meter only or the HISS light, bright and oil light as well. clock still working? probably a lose connection?



2005 600rr 36300km
2001 Isuzu kb 320 V6 LX double cab 212000km
clx is offline  
post #5 of 11 (permalink) Old 01-22-2013, 06:01 AM
Premium Member
 
Soponcio Virtual's Avatar
 
Join Date: Sep 2012
Location: Madrid - Spain
Posts: 1,641
Thanks: 137
Thanked 271 Times in 216 Posts
Garage
Feedback Score: 0 reviews
Can be that the tacho is unplugged or the plug is loose... or even a fuse...

Is it the only thing that is not working???

Are lights and blinkers OK??



Honda CBR600RR 2003 - Gone! (the blond)

Honda CBR600RR 2007 - On the road! (the brunette)
Soponcio Virtual is offline  
The Following User Says Thank You to Soponcio Virtual For This Useful Post:
Gashuffer (01-22-2013)
post #6 of 11 (permalink) Old 01-22-2013, 11:18 AM
World Superbike Racer
 
Gashuffer's Avatar
 
Join Date: Oct 2009
Location: Chicago Burbs
Posts: 1,718
Thanks: 96
Thanked 93 Times in 87 Posts
Feedback Score: 5 reviews
tach doesnt work?

^ that's what I was thinking. I know I've had issues with my tach, fuel gage and some other random lights on my cluster because the 50 pin (or whatever it is) plug in the back wasn't fully seated.


Sent from Motorcycle.com App

Give a man a fish; you have fed him for today. Teach a man to fish; and you have fed him for a lifetime.
Gashuffer is offline  
post #7 of 11 (permalink) Old 01-22-2013, 02:40 PM Thread Starter
Knee Dragger
 
thekw's Avatar
 
Join Date: Apr 2012
Posts: 194
Thanks: 13
Thanked 5 Times in 5 Posts
Feedback Score: 2 reviews
Will check for all of those. I believe the lights all work. I also believe the speedo works and just the rpm meter doesnt work. Ideas? Will it cost to fix alot?



Orange Tribal
-Leo Vince SBK
-DDM hid hi/lo
-the2wheels.com shorty levers
-Galfer wave rotors and breaks
-Progrip rim tape
-Progrip tank cap protector
-Progrip tank protector
-Aftermarket front blinkers
-OPP carbon fiber clutch cover
-OPP carbon fiber motor cover
-Side plate mount
-Double bubble smoked windscreen
-Shorai battery
-Integrated tail light
thekw is offline  
post #8 of 11 (permalink) Old 01-22-2013, 07:03 PM
Knee Dragger
 
Lobster's Avatar
 
Join Date: Jan 2013
Location: Carrollton, GA
Posts: 110
Thanks: 9
Thanked 10 Times in 8 Posts
Feedback Score: 1 reviews
I have (had) the same problem.

I did my research and here's what I came up with (fron fellow members on different threads) :

1) Check the back of the gauge pod. Its fairly commonplace for them to wiggle out.
2) Check fuses. All of them.
3) Check the ECU. Plug and unplug the ECU. If you have a spare ECU or a friend with one, try it.
4) Remove gauge pod. Check the pins to see if any are bent or non-existent.

I did all that and my tach still didn't work. I bought a new gauge pod and it fixed the problem. Still can't put my finger on the problem. I'll probably end up taking the old gauges apart to see if anything is catching the RPM needle or if anythings burned out.

Hope your friend fixes his issue! Happy riding!
Lobster is offline  
The Following User Says Thank You to Lobster For This Useful Post:
thekw (01-23-2013)
post #9 of 11 (permalink) Old 01-23-2013, 11:40 PM Thread Starter
Knee Dragger
 
thekw's Avatar
 
Join Date: Apr 2012
Posts: 194
Thanks: 13
Thanked 5 Times in 5 Posts
Feedback Score: 2 reviews
Thanks lobster for your help.
It is just the tach, was yours just the tach too?
How much does a new cluster cost? and where is a good place to get them?



Orange Tribal
-Leo Vince SBK
-DDM hid hi/lo
-the2wheels.com shorty levers
-Galfer wave rotors and breaks
-Progrip rim tape
-Progrip tank cap protector
-Progrip tank protector
-Aftermarket front blinkers
-OPP carbon fiber clutch cover
-OPP carbon fiber motor cover
-Side plate mount
-Double bubble smoked windscreen
-Shorai battery
-Integrated tail light
thekw is offline  
post #10 of 11 (permalink) Old 01-25-2013, 07:34 PM
Knee Dragger
 
Lobster's Avatar
 
Join Date: Jan 2013
Location: Carrollton, GA
Posts: 110
Thanks: 9
Thanked 10 Times in 8 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by thekw View Post
Thanks lobster for your help.
It is just the tach, was yours just the tach too?
How much does a new cluster cost? and where is a good place to get them?
Mine was just the tach. Mileage worked, gas gauge worked, lights illuminated.

When I got the bike, the RPM needle was stuck at 2,000 and when I'd rev the bike, the needle would wiggle ever so slightly.

A new cluster on eBay can run 150-300+ dollars. Locally on Craigslist shows many more (I found 3 when I was looking) for a lot lower. I got mine off Craigslist for 100 dollars. Works fine now!

Last edited by Lobster; 01-25-2013 at 07:37 PM.
Lobster is offline  
post #11 of 11 (permalink) Old 01-25-2013, 07:36 PM
Knee Dragger
 
Lobster's Avatar
 
Join Date: Jan 2013
Location: Carrollton, GA
Posts: 110
Thanks: 9
Thanked 10 Times in 8 Posts
Feedback Score: 1 reviews
Also beware when buying a new gauge cluster. I located a 2007 gauge cluster and searched on the forums to see if it'll fit. People said it uses the same plug and will fit perfectly. They claimed plug and play but they never told me that the main stay bracket would not line up with the mounting holes. I discovered this after I bought it.

So in other words, don't buy a 2007+ gauge unless you plan on cutting your main stay bracket like I did.
Lobster is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome