horn failure!!! - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 10-02-2005, 10:32 AM Thread Starter
 
Join Date: Aug 2005
Posts: 3
Images: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy horn failure!!!

hi guys!
my bike's horn is not working, i properly checked all electrical parts such as fuses, relays, wiring, switches etc but could not figure out the failure, i am based quite far away from a honda dealer or mechanic, please help me on this.
amit is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-02-2005, 11:00 AM
 
Join Date: Feb 2005
Posts: 95
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check all fuses and other functions that may not be functioning properly.
Just the horn fuse may not fix it. How did you check the fuses? VOM is the right way.
butchf is offline  
post #3 of 6 (permalink) Old 10-02-2005, 11:28 AM
 
tripage's Avatar
 
Join Date: Jun 2004
Location: orlando
Posts: 14,330
Thanks: 598
Thanked 728 Times in 591 Posts
Feedback Score: 91 reviews
Check the two wires that connect to the actual horn and the screws that ground it.
tripage is offline  
 
post #4 of 6 (permalink) Old 10-02-2005, 11:38 AM
Knee Dragger
 
ddo01881's Avatar
 
Join Date: Sep 2005
Location: TAMPA BAY!!
Posts: 175
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
man, be glad it doesnt work.. i hate the damn button, i always hit it on accident and I look like an a** in traffic. lol

"Its not how long we live, but how well we live while alive!"
"Don't ride faster than your guardian angels can fly"
http://www.myspace.com/stpete600rr

Mods so far:
PP Tuning Rearsets
Smoke windshield
Hindle full exhaust
Integrated tail light
Fender eliminator
Custom brake res. cover
Carbon fiber mirrors
Power Commander III (back on-what a difference)
ddo01881 is offline  
post #5 of 6 (permalink) Old 10-02-2005, 11:52 AM
Moto GP Racer
 
LonelyRR's Avatar
 
Join Date: Dec 2003
Location: Ithaca, NY
Posts: 3,766
Images: 241
Thanks: 0
Thanked 15 Times in 15 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ddo01881
man, be glad it doesnt work.. i hate the damn button, i always hit it on accident and I look like an a** in traffic. lol
You might look like an A$$Hole but atleast the cages know that your there.


LonelyRR is offline  
post #6 of 6 (permalink) Old 10-02-2005, 11:58 AM
 
Join Date: May 2004
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
With key on, grab your front brake and see if the brake light lights up. Then do the same for the rear brake. If it lights both times, you're wiring is fine, thats where horn gets its power from. You probabaly got some crap in the switch itself from a washing that is coating the contacts. I can't imagine them to be corroded or rusty on a new bike. Spray some contact cleaner in there or take it off and OHM it out with switch in open and closed positions.
I would check for power with a voltmeter at the horn itself to save you all the work of dissasembly first. If it has power and a good ground, it's the component. Hope this helps.
sierra3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
The 600RR Horn schnellcbr General Discussion 27 02-24-2007 03:18 AM
06 horn connector Macgyver46 Troubleshooting 0 12-17-2006 12:11 PM
Different Horn O2BESOHUGE General Discussion 16 05-28-2006 03:52 PM
CBR600RR horn sucks...aftermarket?? Ichiro 03-06 RR Modifications 9 11-02-2005 01:13 PM
new horn danimal 03-06 RR Modifications 14 04-13-2005 09:25 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome