2003-2005 CBR600RR ECU compatibility - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 02-26-2006, 06:57 PM Thread Starter
 
Join Date: Feb 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003-2005 CBR600RR ECU compatibility

Does anyone know if the ECU from an earlier model 03-04 is compatible with a 2005 600RR.
I am in australia and we have the HISS system in our ECU model.
Sourced an 03 ECU and key set and wont start, (cranks over but no fuel pump noise and ignition i think)
Not sure if they changed the computers but i have been told they are compatible.
Has anyone had any experience with this?

I bought the bike stolen/recovered from insurance auction to make a race bike out of it without keys for a good price, but now i am having issues getting it going.

I have tested the tip switch sensor and it is working fine, not sure where i am going wrong.
Checked all fuses and all ok.
Any suggestions?

Thanks in advance
freerider is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 02-26-2006, 07:41 PM
 
Join Date: Sep 2005
Posts: 1,322
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i think they are the same computer but the 05 has a different stock map. other than that dont expect anyone to give you any help on starting a bike without the keys especially being your first post. any joe shmoe can join and say damn guys i lost my keys how do i hotwire a 600RR? you understand
potate311 is offline  
post #3 of 10 (permalink) Old 02-26-2006, 08:48 PM Thread Starter
 
Join Date: Feb 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I do have keys for the 03 computer and it doesnt want to work
the bike is an 05 and i was told it would work no worries
it cranks over, but no fuel pump noise and no firing up!
I thought it would fire up, have the computers changed?
freerider is offline  
 
post #4 of 10 (permalink) Old 02-26-2006, 08:59 PM
Knee Dragger
 
Join Date: Dec 2005
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i was told they are different and wont work
slow1onrr is offline  
post #5 of 10 (permalink) Old 02-26-2006, 09:14 PM
 
Join Date: Sep 2005
Posts: 1,322
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
so if you really do have that stuff why dont you just swap the ignitions
potate311 is offline  
post #6 of 10 (permalink) Old 02-26-2006, 09:21 PM Thread Starter
 
Join Date: Feb 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have an 03 for the road and i just bought an 05 would be track bike damaged from the auctions without keys.
trying to get it going with the 03 bits but it seems impossible
freerider is offline  
post #7 of 10 (permalink) Old 11-21-2011, 04:14 AM
Training Wheel Hero
 
Join Date: Jun 2011
Location: JHB,South Africa
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I tried an 05 ecu and keys on the 03 and i'm have the same issue as you.So i dont think it will work
Shogunn is offline  
post #8 of 10 (permalink) Old 11-21-2011, 06:58 AM
Training Wheel Hero
 
Join Date: Nov 2011
Posts: 92
Thanks: 21
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
if you bought the ecu and keyset from the wreckers i would return it and get a refund.

as you are the new owner of the motorcycle, take your receipt to a honda dealer to get them to get you a new key with a matching transponder in it. i have no idea if they have it cut for you, but if they dont take it to a locksmith with the bike to have it cut. remember to put back the original ignition though, thats if you changed it with the 03 keys you got.
crzie is offline  
post #9 of 10 (permalink) Old 11-22-2011, 02:26 AM
Administrator
 
Nico's Avatar
 
Join Date: Apr 2010
Location: Adelaide
Posts: 13,137
Thanks: 135
Thanked 1,530 Times in 1,047 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by Shogunn View Post
I tried an 05 ecu and keys on the 03 and i'm have the same issue as you.So i dont think it will work
It will if you swap the harness as well.
Nico is offline  
post #10 of 10 (permalink) Old 11-28-2011, 02:39 PM
AMA Supersport Racer
 
doofiep007's Avatar
 
Join Date: Sep 2003
Location: Clermont
Posts: 936
Thanks: 0
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
there are a couple sensor that have different plugs...T has a 05 engine on a 04 harness and ive got a 07 pc3 on a 03. it will all work but how far are you willing to cut/solder

doofiep007 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome