Watsen's Install Help - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 20 (permalink) Old 03-25-2006, 01:19 AM Thread Starter
Impreza The Impressive
 
ImprezaWrx9's Avatar
 
Join Date: Jun 2005
Posts: 896
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 6 reviews
Watsen's Install Help

when i put my signals on, they won't fit because the screw is too long and it's poking into my ram air tubes.




How long is it supposed to be? i measured it and it's about an inch long or 3mm long. Should i get them cut shorter? if so, how short should it be so it'll fit? am i installing them correctly? Thanks


ImprezaWrx9 is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 03-25-2006, 01:20 AM
 
Join Date: Jun 2005
Posts: 1,821
Images: 63
Thanks: 0
Thanked 14 Times in 7 Posts
Feedback Score: 0 reviews
umm try them with the stock bracket inside i think, unless they made the design differently they should fit fine....? good luck...dont make me pull off my front fairing...and from the first pic...it looks backwards...lol

Last edited by BiGxbOix510; 03-25-2006 at 01:25 AM.
BiGxbOix510 is offline  
post #3 of 20 (permalink) Old 03-25-2006, 01:24 AM Thread Starter
Impreza The Impressive
 
ImprezaWrx9's Avatar
 
Join Date: Jun 2005
Posts: 896
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 6 reviews
Quote:
Originally Posted by BiGxbOix510
umm try them with the stock bracket inside i think, unless they made the design differently they should fit fine....? good luck...dont make me pull off my front fairing lol
even if the bracket does go inside, it still doesn't fit. that screw won't go in any further because it's poking my ram air tubes. The only thing i can think of is to cut them shorter but wanted to know if anyone else had the same problem as me. Thanks for the reply and yes you should take off your front fairing and measure your screw =) j/k
ImprezaWrx9 is offline  
 
post #4 of 20 (permalink) Old 03-25-2006, 01:29 AM
 
Join Date: Jun 2005
Posts: 1,821
Images: 63
Thanks: 0
Thanked 14 Times in 7 Posts
Feedback Score: 0 reviews
are you putting them in facing the right way? the more LED's to the front and the 2 LEDs facing the back.


lol nm, i i thought that was on the right side...whoops! lmao
BiGxbOix510 is offline  
post #5 of 20 (permalink) Old 03-25-2006, 01:32 AM Thread Starter
Impreza The Impressive
 
ImprezaWrx9's Avatar
 
Join Date: Jun 2005
Posts: 896
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 6 reviews
Quote:
Originally Posted by BiGxbOix510
are you putting them in facing the right way? the more LED's to the front and the 2 LEDs facing the back.


lol nm, i i thought that was on the right side...whoops! lmao
hahahaha the picture was taking from the front so that's the right side if you're looking at it from the front. Did you put the bracket on the inside or on the outside of the fairing?
ImprezaWrx9 is offline  
post #6 of 20 (permalink) Old 03-25-2006, 01:41 AM
 
Join Date: Jun 2005
Posts: 1,821
Images: 63
Thanks: 0
Thanked 14 Times in 7 Posts
Feedback Score: 0 reviews
I believe the piece of the bracket that sticks out a bit, I stuck the wiring through there (inside). GOOD LUCK! SOMEONE HELP THIS MAN! MY BRAIN TOOK A VACATION! =P

Last edited by BiGxbOix510; 03-25-2006 at 01:43 AM.
BiGxbOix510 is offline  
post #7 of 20 (permalink) Old 03-25-2006, 01:42 AM
 
Join Date: Jun 2005
Posts: 1,821
Images: 63
Thanks: 0
Thanked 14 Times in 7 Posts
Feedback Score: 0 reviews
O WAIT...i think this is easy....pull off the tube...mount the signal, then put the tube back on...should have no problems...try it, lol
BiGxbOix510 is offline  
post #8 of 20 (permalink) Old 03-25-2006, 01:48 AM Thread Starter
Impreza The Impressive
 
ImprezaWrx9's Avatar
 
Join Date: Jun 2005
Posts: 896
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 6 reviews
are you sure? because if it doesn't fit with the tube on, what makes you think that it would with when i take it off and then put back on? will the tube still be in the way?

Last edited by ImprezaWrx9; 03-25-2006 at 01:52 AM.
ImprezaWrx9 is offline  
post #9 of 20 (permalink) Old 03-25-2006, 01:51 AM
 
Join Date: Jun 2005
Posts: 1,821
Images: 63
Thanks: 0
Thanked 14 Times in 7 Posts
Feedback Score: 0 reviews
move everything out of the way tighten the nut and put all the ram air stuff back on...if it's still bad.....you can always cut it. =P

Last edited by BiGxbOix510; 03-25-2006 at 01:54 AM.
BiGxbOix510 is offline  
post #10 of 20 (permalink) Old 03-25-2006, 01:52 AM Thread Starter
Impreza The Impressive
 
ImprezaWrx9's Avatar
 
Join Date: Jun 2005
Posts: 896
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 6 reviews
yeah i was gonna cut it but wanted to know if anyone had the same problem or no problem at all or i wasn't doing it rite
ImprezaWrx9 is offline  
post #11 of 20 (permalink) Old 03-25-2006, 01:55 AM
 
Join Date: Jun 2005
Posts: 1,821
Images: 63
Thanks: 0
Thanked 14 Times in 7 Posts
Feedback Score: 0 reviews
mine was no problem, noone else seems to be interested in this thread.
BiGxbOix510 is offline  
post #12 of 20 (permalink) Old 03-25-2006, 01:57 AM Thread Starter
Impreza The Impressive
 
ImprezaWrx9's Avatar
 
Join Date: Jun 2005
Posts: 896
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 6 reviews
welps, guess i'll cut them. Thanks BIG
ImprezaWrx9 is offline  
post #13 of 20 (permalink) Old 03-25-2006, 02:03 AM
 
Join Date: Jun 2005
Posts: 1,821
Images: 63
Thanks: 0
Thanked 14 Times in 7 Posts
Feedback Score: 0 reviews
ebay owned you! next time, get them directly from watsen! $120 USD shipped or $60 per piece.
BiGxbOix510 is offline  
post #14 of 20 (permalink) Old 03-25-2006, 09:19 AM
Back in the Day
 
Moeman's Avatar
 
Join Date: Jul 2003
Location: Central Florida
Posts: 51,143
Images: 665
Thanks: 2,026
Thanked 2,544 Times in 2,156 Posts
Feedback Score: 148 reviews
i got the ones from Watsens himself and had no issues installing them



If it doesn't challange you it won't change you
Only two ways to live life. One is as though nothing is a miracle. The other is as though everything is a miracle.
Moeman is offline  
post #15 of 20 (permalink) Old 03-25-2006, 12:29 PM Thread Starter
Impreza The Impressive
 
ImprezaWrx9's Avatar
 
Join Date: Jun 2005
Posts: 896
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 6 reviews
Quote:
Originally Posted by BiGxbOix510
ebay owned you! next time, get them directly from watsen! $120 USD shipped or $60 per piece.
the guy selling them on ebay is the guy from watsen himself and they are from canada. his ebay sn is baysideperformance if you wanna take a look for yourself.
ImprezaWrx9 is offline  
post #16 of 20 (permalink) Old 03-25-2006, 02:37 PM
 
Join Date: Jan 2005
Posts: 223
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Pretty sure you're not going to hurt anything by cutting them shorter. Might as well do it and get them installed.
mikehal is offline  
post #17 of 20 (permalink) Old 03-25-2006, 08:17 PM Thread Starter
Impreza The Impressive
 
ImprezaWrx9's Avatar
 
Join Date: Jun 2005
Posts: 896
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 6 reviews
yup, i got them cut to 2cm and they fit perfectly. pictures here

https://www.600rr.net/vb/showthread.p...934#post599934
ImprezaWrx9 is offline  
post #18 of 20 (permalink) Old 03-25-2006, 09:34 PM
World Superbike Racer
 
Join Date: Jul 2005
Posts: 2,346
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Looks good. I didn't have any problem with mine. I found it was easiest to pull the whole upper forward a little to access the signal bolts. I am glad you got them on.
600rrrider is offline  
post #19 of 20 (permalink) Old 03-25-2006, 09:46 PM
 
Join Date: Jun 2005
Posts: 1,821
Images: 63
Thanks: 0
Thanked 14 Times in 7 Posts
Feedback Score: 0 reviews
Looks Nice+Bright! Glad you got it to work out.
BiGxbOix510 is offline  
post #20 of 20 (permalink) Old 03-27-2006, 10:08 PM
 
Join Date: Mar 2006
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just Cut The Screw Down...and Your Golden
600rrJ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome