lights staying on electrical problem - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-29-2014, 07:59 AM Thread Starter
Training Wheel Hero
 
Join Date: Jul 2014
Location: Alberton , South Africa
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
lights staying on electrical problem

Hi People, i am in need of some help please,

My indicators stay on, and the head light is very weak, brights do not come on either,
Removed the 3 relays on the left by the fairing but the indicators still stay on, if i put the indicator on left and right goes on and off,

i stripped the bike and checked to see if i can spot a burnt wire or something but no luck, i also check the kill switch and the light switch housings for loose wires but nothing

any ideas, thank you in advance

2005 RR

Last edited by licardo; 07-29-2014 at 08:01 AM. Reason: detail missing
licardo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome