Front Turn signals , third eye not working - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 09-02-2014, 11:40 PM Thread Starter
Training Wheel Hero
 
Join Date: Aug 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Front Turn signals , third eye not working

Guys I cant figure out this issue.

I have LED flush mount front turn signals, integrated tail light, CustomLED relay.

My rear signals on my tail light work properly and blink at the proper rate.

My front signals do not work at all. Another weird thing is that the turn signal indicator on my gauge cluster does not work. Everything else on the gauge cluster works just fine. My integrated tail will be blinking properly but neither the front turn signals or gauge cluster blinks.

My third eye also is not coming on. I have checked all of the fuses. I know the front signals are wired correctly.

I am waiting on the headlight sockets to finish my bike and do not have the headlights plugged up yet; I dont know if that matters.

Any help much appreciated.

Thanks

Last edited by Vader; 09-02-2014 at 11:44 PM.
Vader is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome