600 RR3 No indicators on the front! - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 10-31-2014, 03:17 PM Thread Starter
Training Wheel Hero
 
Join Date: Nov 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
600 RR3 No indicators on the front!

I recently put a tail/stop light with integrated indicators on the rear (all works fine) i also fitted front led indicators at the same time, now the rears still work fine but the fronts dont work at all! I put the factory fronts back on and they now no longer work! I had a look earlier at the wiring and all seems ok but since re installing the battery to see if me playing with the wires helped i now dont have the speedo display fuel display or neutral light but the indicator on the dials still flashes! PLEASE HELP!!
yan_buys_parts is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-31-2014, 04:56 PM
AMA Supersport Racer
 
Lyoha's Avatar
 
Join Date: Apr 2014
Location: Annapolis Area
Posts: 862
Thanks: 14
Thanked 172 Times in 151 Posts
Feedback Score: 0 reviews
Did you remove the battery when you did the install at first? If you didn't, you could easily short a wire to ground and pop a fuse. Check your fuse box. That's the best case.

If I remember right, you have to take off the front cowl air ducts off to get to the back sides of the front turn indicators. Worst case, you pulled some wire during the install and lost either a ground or feed somewhere up in the nose. Look for that. Wiring diagram and a multimeter here will be your best friend.

Last edited by Lyoha; 10-31-2014 at 05:08 PM.
Lyoha is offline  
post #3 of 3 (permalink) Old 10-31-2014, 06:47 PM Thread Starter
Training Wheel Hero
 
Join Date: Nov 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the response, I will give that a look in the morning.
yan_buys_parts is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome