Gauge/Turn Signal Problems 2012 600rr - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 02-02-2015, 01:02 PM Thread Starter
Training Wheel Hero
 
Join Date: Feb 2015
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Gauge/Turn Signal Problems 2012 600rr

I have a 2012 CBR600rr that I laid down at the end of last season. In the process of rebuilding the damaged areas I have discovered that my front turn signals, third eye (middle light), and the gauges aren't working. The front lights work fine, but the only thing that shows up on my gauges is the clock. The fuel pump works and the bike starts just fine. Could this be a fuse or a more complicated fix? Any ideas would be greatly appreciated.
idontknowwhatimdoing is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-02-2015, 02:08 PM
 
tripage's Avatar
 
Join Date: Jun 2004
Location: orlando
Posts: 14,330
Thanks: 598
Thanked 728 Times in 591 Posts
Feedback Score: 91 reviews
Check your fuses..




http://tripageled.com/store/
Owner
Tristan Page
[email protected]
[email protected]
Dual low / Dual High beam led headlights. OEM appearance
http://tripageled.com/store/index.ph...product_id=236
Integrated Gear Indicator installed inside your cluster
http://tripageled.com/store/index.ph...product_id=116
tripage is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome