Kill Switch/Start/Brake light harness issue - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-31-2015, 11:34 PM Thread Starter
Training Wheel Hero
 
Join Date: Jun 2014
Location: Milwaukee, WI
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Kill Switch/Start/Brake light harness issue




Ive traced the problem to that grey plug. As the title states, thats what that plug controls from what I can see. My issue is that if I knock bump even touch that plug my headlights, kill switch brake light flickers. I'm pretty sure its a loose connection but the connector plugs in all the way and doesn't come loose. How would I go about fixing an internal issue with a connector?

My bike is a 2008 Honda CBR600RR Graffiti Edition

Dan Iwanski
Milwaukee, WI
08 600RR Graffiti Edition
Alphatango2 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-01-2015, 07:31 PM
Moto GP Racer
 
Bridge_Jumper's Avatar
 
Join Date: May 2012
Location: Land O' Cheese
Posts: 7,440
Thanks: 370
Thanked 1,167 Times in 990 Posts
Feedback Score: 5 reviews
Check to see if any of the pins are bent. If they are, straighten them out

Check to see if any wires wiggle in the connector. If they do, make them stop wiggling

2006 Honda CBR600RR Black Tribal Edition
2W1R - IceTitan
Bridge_Jumper is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome