Tick noise when off - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 06-13-2017, 04:21 AM Thread Starter
Training Wheel Hero
 
ghostface22's Avatar
 
Join Date: May 2017
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tick noise when off

Ok so I just installed a power commander v today and loaded a map from dyno jet, same year same mods (2013) and she runs great better than before, but now I hear this tick sound kinda like cars do when you turn them off. My bike has never made the sound before the install today I'm just concerned if it was normal or is it something to do with it running more rich or lean. Oil is good and the only mods are a slip on tbr. Thanks guys
ghostface22 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome