Please help - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 04-23-2018, 01:26 AM Thread Starter
Training Wheel Hero
 
Join Date: Apr 2018
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Please help

I have a 2012 600 and it won’t charge What I have done. I put a new stator in the bike and after the new one the voltage I get is 6-7 volts AC at idle around 19 at 5k. And then I replaced the rectifier and with the stator plugged in but not coneected to the battery I get 15 volts DC but as soon as I plug it into the rest of the bike it matches the battery voltage what ever that may be at no time do I get anywhere near 13-14 volts at the battery while the bike is running ever at rmp Also I just put in a brand new battery so. I have replace all 3 main components and still have an issue. The bike has only 1400 miles on it. Please help.
Jslhutch is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-30-2018, 05:50 AM
Training Wheel Hero
 
Gaya's Avatar
 
Join Date: Apr 2018
Posts: 11
Thanks: 1
Thanked 1 Time in 1 Post
Garage
Feedback Score: 0 reviews
geez... that's low in terms of milage... are all the cables still in good nick?

I mean wires when i say cables...sorry...


Last edited by Gaya; 04-30-2018 at 05:51 AM. Reason: language
Gaya is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome