Dash Cluster not working - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 09-23-2018, 05:24 PM Thread Starter
Training Wheel Hero
 
Join Date: Dec 2012
Posts: 8
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dash Cluster not working

Hi All

Recently had a off and damaged the front nose cone.

Got the bike back and stripped it down not as bad as I thought it would be..

Only problem I have come across is the dash cluster is not working it lights up but the

MPH / TEMP / MILEGAE / FUEL / SPEEDO NEEDLE ARE NOT WORKING OR DISPLAYING, had water damage

Gave it a to a local electriction who has replaced a few things.!!! still not working
I have treid another clock off a friend and all works.!!!


I have attach photo if anyone can help me or give me some idea

Thanks in advance
Attached Thumbnails
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20180920-173545_Gallery.jpg
Views:	32
Size:	84.3 KB
ID:	199965  
bkcbr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-23-2018, 06:07 PM
Pocketbike Racer
 
Wazoo's Avatar
 
Join Date: Sep 2018
Location: Windsor, CT
Posts: 304
Thanks: 151
Thanked 66 Times in 61 Posts
Feedback Score: 0 reviews
Define "had water damage"?
I don't think I can help, other than to suggest that you thoroughly dry it out. There are numerous ways to dry it, but whatever way you use, open up and expose as much of the insides as possible, and don't overtemp anything (don't melt it!). Best way may be to get a very low humidity environment, and use a dry heat up to about 130 deg F or so. A fan directed at the speedo will speed up the process. You also could have fried a component on the circuit board, in which case, this won't help. Good luck.
Wazoo is offline  
The Following 2 Users Say Thank You to Wazoo For This Useful Post:
bkcbr (09-24-2018), dixon cider (09-23-2018)
post #3 of 4 (permalink) Old 09-23-2018, 06:14 PM
Lifetime Premium
 
dixon cider's Avatar
 
Join Date: Aug 2016
Location: Southwest USA
Posts: 343
Thanks: 5,176
Thanked 65 Times in 61 Posts
Garage
Feedback Score: 0 reviews
How about a used one off ebay? https://www.ebay.com/itm/07-12-Honda...pawzVf&vxp=mtr

First time rider over 40. Finally made it!
dixon cider is offline  
The Following User Says Thank You to dixon cider For This Useful Post:
bkcbr (09-24-2018)
 
post #4 of 4 (permalink) Old 09-24-2018, 02:20 PM Thread Starter
Training Wheel Hero
 
Join Date: Dec 2012
Posts: 8
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It rained somehow got water in the clock when I collected from the garage but did not relised till a few days later..

I have taken apart left it to dry and ended up with no display!!!!!!

bkcbr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome