Turn Signals And Horn Dont Work. (dropped It On Sun) - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 03-13-2007, 10:59 AM Thread Starter
Training Wheel Hero
 
Join Date: Jun 2006
Location: CLIFTON NJ
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turn Signals And Horn Dont Work. (dropped It On Sun)

Drop My Bike On Sunday 06 600RR (4200 MILES) And The HOrn And Turn Signals Dont Work. When I Put The Turn Signal On The Front Signal Will Turn Off. Front Head Lights Work And Back Light Is On. (intergarated Light In Back)

Last edited by PR ASSASSIN; 03-19-2007 at 11:25 AM.
PR ASSASSIN is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-13-2007, 11:26 AM
 
Join Date: May 2004
Posts: 5,131
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
what side did you drop it on, and have you checked all your fuses?
usmcr6 is offline  
post #3 of 8 (permalink) Old 03-19-2007, 11:22 AM Thread Starter
Training Wheel Hero
 
Join Date: Jun 2006
Location: CLIFTON NJ
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Droped It On The Left Side Have Not Checked The Fuses. When I Use The Turn Signal On Either Left Or Right That Side Front Signal Light Will Go Off.
PR ASSASSIN is offline  
 
post #4 of 8 (permalink) Old 03-19-2007, 02:04 PM
 
Join Date: Mar 2007
Posts: 244
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the fuses....I can almost bet you blew one...
1sikCBR is offline  
post #5 of 8 (permalink) Old 03-19-2007, 03:42 PM Thread Starter
Training Wheel Hero
 
Join Date: Jun 2006
Location: CLIFTON NJ
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
will check fuses this week. thanks
PR ASSASSIN is offline  
post #6 of 8 (permalink) Old 03-20-2007, 09:16 AM
Knee Dragger
 
Join Date: Sep 2006
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
if the fuese as all ok. Then obviously the next thing would probably be a pinch wire. I would check under the left ram air tube to make sure all the connectors on that side are ok. Any pictures of the damage so that we can give you a better "educated guess"?
hydouken is offline  
post #7 of 8 (permalink) Old 03-20-2007, 03:13 PM Thread Starter
Training Wheel Hero
 
Join Date: Jun 2006
Location: CLIFTON NJ
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
This Weekend Is Supposed To Be Warm So Will Check Fuses And Post Pics. Nothing Broke Bunch Of Scratches. WHERE ARE THE FUSES LOCATED.

Last edited by PR ASSASSIN; 03-20-2007 at 03:15 PM.
PR ASSASSIN is offline  
post #8 of 8 (permalink) Old 03-23-2007, 08:56 PM
Pocketbike Racer
 
Tules's Avatar
 
Join Date: Oct 2006
Location: Quincy, IL
Posts: 329
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
most liekly fuses

Black 06 600rr
Jardine Rt-One
PCIII w/custom map
BMC Race filter
520 Chain conversion
Jardine FE
Competition Werkes Flush mounts
Pilot Powers



Tules is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome