brake question - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 04-05-2007, 10:05 PM Thread Starter
Pocketbike Racer
 
e-flores's Avatar
 
Join Date: Oct 2006
Location: franklin, ohio
Posts: 498
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 3 reviews
brake question

ok i have been practicing hard braking latelly and i keep hearing a clicking noise from the front rotors is this normal???

e-flores is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-05-2007, 11:41 PM
Training Wheel Hero
 
jmoto's Avatar
 
Join Date: Jul 2006
Location: everywhere
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
braking

yes sometime you will hear a clicking noise. if i remember correctly it has something to do with the rotors expanding and the pads going over the holes in the rotors. i think
pls do not trust me on this you can trust me on the noise just not on exactly what is making the noise


2006 Black CBR 600RR
Ohlins steering damper
P/C swingarm
Yoshimura slip-on/with no cat
Zero Gravity windscreen
Pilot power tires
RK 520 quick accel kit
PowerCommander
Ignition module
Velocity stacks
PAIR mod
BMC race filter
Woodcraft rearsets
myspace page:
http://www.myspace.com/jmotomotorsports






jmoto is offline  
post #3 of 4 (permalink) Old 04-05-2007, 11:48 PM
AMA Supersport Racer
 
JSS829's Avatar
 
Join Date: Dec 2005
Location: Austin
Posts: 601
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Its because the pad is floating in the caliper....

https://www.600rr.net/vb/showthread.p...brake+clicking


Two Brothers Slip on
Harris Frame Sliders
Pilot Powers
Custom FE
Ohlins .95 Fork Springs
Ohlins Fork Valves
-1/+2 w/ oem 525 chain
Shock Racing turn signals
EBC HH Sinter Pads
JSS829 is offline  
 
post #4 of 4 (permalink) Old 04-06-2007, 09:25 AM Thread Starter
Pocketbike Racer
 
e-flores's Avatar
 
Join Date: Oct 2006
Location: franklin, ohio
Posts: 498
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 3 reviews
thanks alot guys i was thinking there was something seriously wrong.
or i had abs and i had no idea......
but its all good.

e-flores is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome