Problems setting trip odometer and clock - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-15-2007, 10:12 PM Thread Starter
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Problems setting trip odometer and clock

Yep, I picked up my 2003 600rr up last friday. I was working on it today and I couldnt get the clock to reset. I filled it up a few days ago, and it wouldnt reset, I pushed it several times, and nothing happened. After I rode about a mile or two i noticed it went back to zero. It wont do it though whenever I push it in.

Also I could not get it to go into the mode where you reset the clock.

Any hints on what to do.

I did it with the key in the on postion. So i dont know whats up.
redrider69 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-15-2007, 11:00 PM
Knee Dragger
 
Nor Cal REDD SLEDD's Avatar
 
Join Date: Mar 2004
Location: Northern Calif.
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have an 04 and it just happened to me a couple of weeks ago. Behind the rubber buttons are two plastic actuators , mine on the reset side broke off and is rattling around in the cluster . If you push your buttons and can't feel any click then they are broken. Pretty common problem with these bikes. Do a search you will find a bunch of info about this problem.
Nor Cal REDD SLEDD is offline  
post #3 of 5 (permalink) Old 04-16-2007, 08:13 AM Thread Starter
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Oh really, that sucks. Is there away to fix it?
redrider69 is offline  
 
post #4 of 5 (permalink) Old 04-16-2007, 12:25 PM
Knee Dragger
 
Nor Cal REDD SLEDD's Avatar
 
Join Date: Mar 2004
Location: Northern Calif.
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
some guy's are taking there gauge clusters out and taking it apart and gluing the broken piece back in. My bike is still under warranty & I'm going to have the dealer repair it. Do a search and you find the fix I'm talking about.
Nor Cal REDD SLEDD is offline  
post #5 of 5 (permalink) Old 04-16-2007, 12:38 PM
Back in the Day
 
Moeman's Avatar
 
Join Date: Jul 2003
Location: Central Florida
Posts: 51,143
Images: 665
Thanks: 2,026
Thanked 2,544 Times in 2,156 Posts
Feedback Score: 148 reviews
redrider
Check out this thread
https://www.600rr.net/vb/showthread.p...=reset+buttons



If it doesn't challange you it won't change you
Only two ways to live life. One is as though nothing is a miracle. The other is as though everything is a miracle.
Moeman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome